What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My calculation widget formula is not matching results

    Asked by Jerole on December 01, 2016 at 01:08 PM

    Hi,

    This is a poser. I duplicated a calculation widget field, and changed the formula.

    When you test it online. The calculation is correct. If you open the widget, the formula is from the field I duplicated.

    I have 2 fields with this oddity. Tab 3, the 2nd and 3rd matrix groups.

    Short of redoing the long calculations again, what could be causing this. I have rebooted, and cleared my cache.

     

     

     

    Page URL:
    https://form.jotform.com/63075980288164

    cache calculations 3 and
  • Profile Image
    JotForm Support

    Answered by KadeJM on December 01, 2016 at 02:32 PM

    I'm not sure if I am understanding your issue correctly or not but, it seems to me that you might be referring to the duplicated widget calculation formula not matching though this is slightly confusing since you said that you are changing it.

    Is this https://form.jotform.com/63075980288164  the original form that you were cloning from to then change the formula? Or is it the one with the formula that you changed?

    What is it before? And what are you changing it to now than if so?

    What sort of results were you expecting from it that weren't matching?

    From what I am seeing currently everything is returning as " 345 " and "325" but, this is because that is how you have those conditions set at the moment.

  • Profile Image

    Answered by Jerole on December 01, 2016 at 02:45 PM

    Yes, that is the form.

    I put in a formula in a subtotal field for a matrix.

    I preview and test it. Fine.

    I duplicate the field (it's easier to navigate instead of adding the calc widget).

    I place it under a different matrix, and change the formula to match those items.

    Preview, test.

    Yesterday, all were complete, tested and worked.

    Today I come back and 3-4 of them worked online, but the actual formulas had gone back to the duplicated fields.

     

     

  • Profile Image

    Answered by Jerole on December 01, 2016 at 02:47 PM

    BTW I am also getting error on save messages. And my forms disappeared for a while.

    Wondering if there is a Jot Form issue?

  • Profile Image

    Answered by Jerole on December 01, 2016 at 06:31 PM

    I have all the calculations working now with one major exception.

    When I use fill form in the preview. The Subtotal for page 2 fills in.

    If I fill in the form online - it does not fill in. I have redone the field too many time to mention.

     

     

  • Profile Image
    JotForm Support

    Answered by david on December 01, 2016 at 06:53 PM

    As far as I know, we are not currently having any server issues or anything of that nature.  Nothing that would cause form to be unable to save edits. 

    As far as the calculation widget goes, I am looking into that now.  It is taking a bit of time to recreate the calculation but I am able to see the field that is not updating correctly.

     

  • Profile Image
    JotForm Support

    Answered by david on December 01, 2016 at 06:56 PM

    I deleted the calculation field that was not working correctly, added a fresh one and set up the calculation once again.  It appears to work properly after doing so.  Here is my test copy of the form with the working calculation:

    https://form.jotform.com/63356760199971

    You can clone it to your own account if you would like:

    https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

  • Profile Image

    Answered by Jerole on December 02, 2016 at 08:19 AM

    Thank you!