Distance calculator not working as expected

  • Profile Image
    rbroadfo
    Asked on December 01, 2016 at 01:22 PM

    Distance Calculator, Default Originating Location NOT pre-populating.

     

    I have 6 forms all with the distance calculator and none are pre-populating. 

  • Profile Image
    KadeJM
    Answered on December 01, 2016 at 03:15 PM

    If I am not mistaken I believe you are referring to the driving distance widget, correct?

    When you mentioned pre-populating did you mean it's not showing the address you entered for the origin within the widget?

    I tested this on my end and it seems to be working for me.

    Is this problem still occurring on your end?

    If you meant something else then please clarify or provide a screenshot so we can assist you more.

  • Profile Image
    rbroadfo
    Answered on December 05, 2016 at 02:05 PM

    Yes, I'm referring to the 'driving distance' widget. The widget works when I use Chrome on my phone but it doesn't work when I use Chrome on my computer. 

     

     

     

  • Profile Image
    KadeJM
    Answered on December 05, 2016 at 04:03 PM

    Okay, thanks for confirming that for us and we appreciate the further clarification.

    You mentioned it works on your phone but not on desktop in chrome.

    Can you try visiting this form https://form.jotform.com/63396251435963 which has just a driving widget on it to see if the default location I set for " Palm Bay, FL 32905 " is visible on your end?

    First try checking Chrome to make sure you have the "gps location" enabled.

    It should be set to Ask by Default or Enabled to work. Otherwise, if it is blocked or not allowed by another application then your computer's browser would ignore the field usage which might possibly explain it not working.

    Screenshot:

     

    If for some reason this is still a problem then please let us know and answer these 2 questions -

    What OS are you using on your computer that it's not working?

    Also, what version of Chrome on your computer do you have?

     

  • Profile Image
    rbroadfo
    Answered on December 05, 2016 at 04:25 PM

    I've included screen shots of the chrome settings. I'm using Windows 10 Home. Chrome Version 54.0.2840.99 m

     

     

  • Profile Image
    jonathan
    Answered on December 05, 2016 at 08:25 PM

    I test the widget on the form https://form.jotform.com/63396251435963 but I also could not reproduce the problem on my desktop browsers.

    on Chrome

     

    on Firefox

     

    Can you please try it also using incognito or private mode of your desktop browser.

    Perhaps cache content were blocking the widget. Try also resetting your browser if possible.

    Hope this help. Let us know if you are still not able to make it work on your desktop browser.

    Thanks.

     

  • Profile Image
    owen
    Answered on December 06, 2016 at 02:27 AM

    Hi,

    If by any chance you have posted a response to this thread it somehow failed to reach us. Please kindly re-send your response if you already did so we can provide you assistance. 

    Thank you

  • Profile Image
    owen
    Answered on December 06, 2016 at 09:49 AM

    Hi, 

    I have also tried the widget on several browsers. It seems to be working as expected. If you could provide us the screenshot of the console errors when you reproduce the issue it'd be a huge step forward for us to investigate it further. Here is how you can reach the browser console:

    However, when I open the console as seen in the screenshot I encountered an error message saying that you have reached the API limit for your google maps account. Could the issue be related to that?

    We will be waiting for your feedback.

    Thank you

  • Profile Image
    rbroadfo
    Answered on December 07, 2016 at 11:05 AM

    I'll leave it there. Thanks for the support! 

     

    I'm going to add an option in case customers encounter problems with the widget.