Payment Wizard: Existing product is missing from the wizard, preventing re-ordering of other products

  • Profile Image
    TSellers
    Asked on December 03, 2016 at 03:51 AM

    I have a number of items in a Purchase Order form. If I create a new item and it gets populated at the bottom, I cannot move it up in the list.

     

    Also, in the list, I see the items jump from #6 to #8, after the original #7 was deleted, the rest did not reset.

  • Profile Image
    Boris
    Answered on December 03, 2016 at 04:43 AM

    Thank you for bringing this to our attention. I have checked your provided form, and on first sight, I see that the items are not being numbered correctly by the Payment Wizard:

    I also see that the item where the numbering discrepancy starts cannot be re-ordered (re-positioned):

    There aren't any errors in the browser console.

    I noticed that the payment wizard starts behaving correctly when product "TYT TH-UV8000D" is removed, and I can also see on your live form a product named "Anytone 3318 Car Charger Kit $ 13.95", which does not appear in the Payment Wizard:

    Let me forward this issue to our developers for closer inspection, and we will update you through this support thread when there are any news in this regard. Thank you.

  • Profile Image
    TSellers
    Answered on December 03, 2016 at 11:00 AM

    THanks for looking into that.

     

    FWIW, I did notice that if I took and item and moved it down, then up, then down again, etc., eventually I could get it to move up the line. I also noted an odd behaviour while doing this, for example if it was #9, if you pulled it downward and tried to move it into position #11, it would then reposition itself at #8. I tried 2 different browsers (CHrome and IE), and logged in and out a few times.

     

    Also worth noting that this behaviour seemed to start after I deleted a number of items.

  • Profile Image
    Welvin
    Answered on December 03, 2016 at 11:59 AM

    I think it's the item Anytone that is causing the problem. The page will jump up when you click the item. This is not the behavior of the form when you click an item. Please try to remove the item in the wizard and add it again. See if the same issue will happen.

    Also, you can re-order the items in the old wizard. I did it in the payment field and the changes are saved. Please try it, https://www.jotform.com?old. Access https://www.jotform.com/?reset to switch back to the new layout.

  • Profile Image
    TSellers
    Answered on December 03, 2016 at 02:02 PM

    THanks Welvin,

    I followed both your suggestions, and as you noted, that worked.

    Thanks for doing that.