Why my forms are getting stuck on "Please Wait..." and never get submitted?

  • Profile Image
    tpr
    Asked on December 05, 2016 at 01:58 PM

    Hello,

    I created 4 forms and the data is not submitting. Please let me know what I need to fix on them so the submit button will work. I tested one with make the upload non mandatory and the others with it mandatory and the form still does not submit to the designated email (s). 

    https://form.jotform.com/tpr/campus-students-self-paced-asu-test

    https://form.jotform.com/tpr/asu-test-prep-grad-form

    https://form.jotform.com/tpr/online-self-paced-asu-test

    https://form.jotform.com/tpr/ultimate-asu-test-prep-pt

    Sincerely,

    Ryan 

  • Profile Image
    Kevin_G
    Answered on December 05, 2016 at 04:37 PM

    After spending some time checking your forms I found there is a widget at the very bottom of your forms, it is labeled as "email" but it seems to be an iFrame, the curious thing is that when I tried to open the widget's wizard it does open the widgets page instead of the wizard. 

    This is because I could not find any error in the web console and the form simply did not send, but what I would suggest you is to remove this widget, this way the form will start working fine. 

    Here's also the link to my cloned form where I was able to replicate the same problem and resolve it by removing the mentioned element: https://form.jotform.com/63396375689981 

    Please if after doing this your forms do not work, do let us know, we will be glad to take other look to your form. 

  • Profile Image
    tpr
    Answered on December 06, 2016 at 10:25 AM

    Thank you. I will try this solution. It worked.  Not sure why the wizard for email varifycation doesn't work.

    -Ryan

  • Profile Image
    Kiran
    Answered on December 06, 2016 at 11:37 AM

    Glad to see that the issue is now resolved by removing the said element. It looks like that you have already removed this element on your forms and I am unable to find it. It might have happened when the widget is not properly loaded while it being added to the form or similar issue. If you experience any issue with any widget, please let us know. We will be happy to take a look again.

    Thank you!