I am still able to submit the form when the required fields are not filled in

  • Profile Image
    eforms
    Asked on May 17, 2012 at 02:14 AM

    I have several "required" fields in my form. I am able to hit the submit button and the form submits, I see it in my reports and I get a "your form has been submitted" page. Now, upon performing a preview while in the editing screen, the submit button does not work and flags the fields which are required; however, upon visiting my live webpage and viewing the form from there, the submit button does not work properly when the required fields are left empty and it passes the form.

    I have another form in the same website that has "required" fields and it does not pass the form when the "required" fields are not filled in. 

    How can one form work properly and the other not? I have checked and double checked all the settings. In fact, at one time both forms performed properly and did not pass the form when none of the "required" fields were left empty.

     

    Thanks for your input.

    Lance

  • Profile Image
    mliz
    Answered on May 17, 2012 at 03:47 AM

    To do further check on this issue can you please post the url of the website where the form was added? There may have been a conflict in the webpage and form's code which could be causing this behaviour.

    We'll await for your response. Thanks!

  • Profile Image
    eforms
    Answered on May 17, 2012 at 12:34 PM
    Yes, this is the web page:
    http://www.askappraiser.net/answer-a-question.html . If you try it on this
    web page, http://www.askappraiser.net/ask-a-question.html , the submit
    button works properly. Thank you for your help.
    Lance
  • Profile Image
    Goldo
    Answered on May 17, 2012 at 01:29 PM

    I just tried to check the direct form url, http://www.jotform.us/form/20898642635161 - and it will not allow you to press submit when the required fields are not filled.

    However, on your website it does the opposite which is weird.

    May we kindly ask you to try re-embedding the form using iFrame so does to avoid conflicts. Let us know if it makes any difference.

  • Profile Image
    eforms
    Answered on May 17, 2012 at 01:57 PM
    Success! Using iFrame seemed to correct the issue. Thank you very much. I
    was simply using the option.
    Thank you!
    Lance
  • Profile Image
    Goldo
    Answered on May 17, 2012 at 02:04 PM

    Glad to know that worked, Lance.