File Uploads: Files with a space in their name are downloading incorrectly

  • Profile Image
    chrismuglia
    Asked on December 07, 2016 at 02:19 PM

    starting just today, all uploaded files are unrecognizable filetypes. mainly jpg's and PDF's.

    these are just 2 forms where i've encountered the problem:

    https://form.jotform.com/22349585897978

    https://form.jotform.com/22396624662964

    not sure why this just started happening. i could open uploaded files just fine yesterday.

  • Profile Image
    Boris
    Answered on December 07, 2016 at 04:54 PM

    We're sorry about this issue, I see that files containing a space in the filename are downloading incorrectly.

    The filename of the downloaded file gets truncated at the first space character in the name, so where a file with the following name was uploaded:

    Baptism master packet 2016-2017.pdf

    The name gets truncated after the first space when we try to download it, so it gets turned into:

    Baptism

    Thank you for bringing it to our attention, this issue has been reported to our developers, and we will let you know through this support thread as soon as it is resolved. Thank you.

  • Profile Image
    chrismuglia
    Answered on December 11, 2016 at 09:21 PM

    just checking the status. i'm not able to open customer's files until this is resolved.

    thanks,

    Jill

  • Profile Image
    Jim_R
    Answered on December 12, 2016 at 12:24 AM

    Hello Jill, I am seeing your thread has already been escalated by Boris and it's currently assigned to one of our Developers.

    Although we won't be able to give you any timeframe, rest assured, we'll keep you apprised on this same thread if/when there's an update.

  • Profile Image
    selen
    Answered on December 13, 2016 at 08:19 AM

    Hi,

    We have solved the problem.

    Kindest Regards,

    Selen

  • Profile Image
    chrismuglia
    Answered on December 30, 2016 at 11:16 AM

    i'm having to click on each download twice before it opens.

    the 1st time, a dialog box opens an unrecognizable filetype. i close that window, click on the link again and it opens fine as a PDF or Word doc, etc.

    can you see what the issue is?!

    thanks.

  • Profile Image
    Mike_G
    Answered on December 30, 2016 at 01:30 PM

    I would like to apologize for any inconvenience, however, I'm not able to reproduce the issue you are having.

    May we know what particular browser you were using when you encountered the issue, please?

    I've used Google Chrome (Version 55.0.2883.87 m) on Windows 10 (in my test) and every time I click the link to the uploaded file on the submission page it always opens a "Save As" window with the file type indicated correctly.

    Can you help us by giving us more details, please? We will greatly appreciate if you can also provide a screenshot of the issue you're having. This way we will be able to easily try to reproduce the issue and determine what would be causing it.

    We will wait for your response. 

    Thank you.

  • Profile Image
    chrismuglia
    Answered on March 09, 2017 at 09:42 PM

    i'm still having trouble opening files with spaces in the filename.

    here is a screen print of what i get...the image on the left is the first window i get. i close that. click the document link again. and then it (usually) opens as a PDF or .doc or whatever type of file it is.

    i usually have to click on each document link twice. 1st time i get the "application/octet-stream" message.

    submission #364902742381723496...after trying 4 or 5 times, i can't get this file to open as a PDF.

  • Profile Image
    Mike_G
    Answered on March 09, 2017 at 11:40 PM

    Thank you for providing us more information, however, I am still not able to reproduce the issue you are having even in Mozilla Firefox.

    In the image you provided, notice that the one on the left shows that the file name is truncated at the "space" character that is why it is showing "application/octet-stream" since the file type was also cut off.

    Do you experience the same issue when using a different browser? Also, can you try if this solution would solve the issue you're having with your Mozilla Firefox?

    We will wait for your response.

    Thank you.