Print Button: It is generating an empty document even when the form is filled.

  • Profile Image
    Deborah.Miller
    Asked on December 07, 2016 at 04:15 PM

    I have the "print" option selected on the submit tool. When clicking print, a blank page happens. When I cancel or print the page I then have errors on the page and cannot submit.

    If I click Preview and submit rather than print on the first page, I can print, but when return to the page, I cannot submit. 

     

    In both cases, the user then has to complete the form again.

  • Profile Image
    Kevin_G
    Answered on December 07, 2016 at 07:42 PM

    I have checked your form, but I could replicate one issue only, using the preview and submit button I can preview, print the form and submit it too. 

    Bue when clicking on the print button directly it does not work and a blank document is generated:

    I have cloned your form and replicated the problem again, I have also turn the option off and then on, but the same problem still happened. 

    I will forward the thread to our second level, this will be checked by our developers and we will let you know when this is resolved. 

  • Profile Image
    gizem
    Answered on October 17, 2017 at 06:43 AM

    Hello,


    The problem was related with "Preview Before Submit" widget. It has been fixed now. You need to delete and add your "Preview Before Submit" widget again. After that print button will work as expected.


    Thank you for your understanding.

  • Profile Image
    Deborah.Miller
    Answered on October 17, 2017 at 01:26 PM

    I replaced the widget and it is still printing blank.

  • Profile Image
    Kevin_G
    Answered on October 17, 2017 at 01:38 PM

    I have just tested the issue and it seems to have gone, here is how it works on my end: 

    15082618751.gif

    Here's my cloned form: https://form.jotform.com/63417729920966 

    I already cleared your forms cache, may you please try again? 

    Let us know if the issue persists. 

  • Profile Image
    Deborah.Miller
    Answered on October 17, 2017 at 01:45 PM

    It did not work for me, then i cleared my own cache and it did work. Thank you!