What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Salesforce Integration not working

    Asked by EKettlewell on December 07, 2016 at 06:46 PM

    I'm trying to set up a Salesforce integration with my JotForms. I have authenticated my account and matched up my Salesforce Fields with my JotForm fields, but none of the form's submissions data is transferring to Salesforce. I have reset my security token multiple times and removed and re-added the Salesforce Integration tool multiple times. Any suggestions as to how to make this work would be greatly appreciated.

    Page URL:
    https://form.jotform.com/63065644782159

  • Profile Image
    JotForm Support

    Answered by Kiran on December 07, 2016 at 10:54 PM

    I have checked the Salesforce integration with a test form and it is working fine at my end. Which Salesforce edition you are having? Please be noted that it is required to have API access in order to integrate Salesforce with JotForm. The API access is enabled with only some editions as mentioned in the Salesforce article below:

    https://help.salesforce.com/HTViewSolution?id=000005140

    Are you using any custom fields to map with the Salesforce? Could you try removing the custom fields from the mapping to see if they are causing the issue?

    Please check and let us know if you need any further assistance. We will be happy to assist. 

  • Profile Image

    Answered by EKettlewell on December 08, 2016 at 11:18 AM

    I have the Enterprise Edition of Salesforce, so API access is enabled. I created a clone of the form and tried the integration only using Standard fields and it worked perfectly. I realized that some of my JotForm field types did not match the field types of their mapped custom field in Salesforce, so I've matched the field types and it seems to be working now. Thanks for your help!

    The next problem I have is that not all of my Salesforce fields are appearing as an option to choose from to map to the fields in my JotForm. Most of the fields I'm looking to map are text and date fields that were newly created in Salesforce, I'm not sure if that is a factor. Some of the fields I am missing are ones that have been in Salesforce for years, so it's not just the new ones that aren't showing. Can you help me solve for this?

    Thanks!

  • Profile Image
    JotForm Support

    Answered by Boris on December 08, 2016 at 11:55 AM

    We're glad to hear that you managed to integrate the fields by ensuring they use proper field types, this is also mentioned in the following guide for reference:

    https://www.jotform.com/help/321-Mastering-SalesForce-with-JotForm

    When it comes to not all fields being pulled in the integration for matching, could you please let us know if these are custom fields that are missing, or standard fields?

    It might help if you take a screenshot of your fields in SalesForce and upload it along with your response in our forum, which you can do by following these instructions:

    https://www.jotform.com/answers/277033-How-to-add-screenshots-images-to-questions-in-support-forum

    As far as I'm aware, standard fields should be showing fine, but there may be issues when using a large amount of custom fields in SalesForce. If you are using a large amount of custom fields, you may want to try bridging the connection between JotForm and SalesForce through a specialized service such as Zapier:

    https://www.jotform.com/blog/164-Automating-Your-Forms-with-Zapier

    https://zapier.com/zapbook/jotform/salesforce/

    Thank you.

  • Profile Image

    Answered by EKettlewell on December 08, 2016 at 01:05 PM

    The missing fields are custom fields. We have roughly 100 custom fields in Salesforce. I'm just trying to understand why some particular custom fields would show and other custom fields not. It seems like a very randomized list of the Salesforce fields we have available. Is there some sort of setting in Salesforce I could change to tell JotForm which fields to exclude or include?

  • Profile Image
    JotForm Support

    Answered by BDAVID on December 08, 2016 at 01:55 PM

    Please provide us a screenshot of the SalesForce custom fields that are not showing in the integration.

    Make sure to load the link to this thread in your browser: https://www.jotform.com/answers/1006315, then include a screenshot as shown on this guide: https://www.jotform.com/answers/277033 

  • Profile Image

    Answered by EKettlewell on December 08, 2016 at 02:47 PM

    I have another JotForm that provides a better example of Salesforce fields not appearing in the integration settings: https://form.jotform.com/63395662161156. None of the custom Salesforce fields that match the fields in this form are showing in the integration. For some reason, almost all of the Salesforce fields needed for the form linked in my first question happened to appear as an option in the integration.

    Here are screenshots of the SF fields not appearing:

     

    And shots showing they aren't appearing in the integration settings:

  • Profile Image
    JotForm Support

    Answered by Kiran on December 08, 2016 at 03:13 PM

    Thank you for sharing the screenshots. Could you confirm if you are trying to integrate to a lead or account or contact so that we'll try to replicate the issue at our end?

    We will wait for your response. Thank you! 

  • Profile Image

    Answered by EKettlewell on December 08, 2016 at 03:14 PM

    This is for a contact.

    Thanks!

  • Profile Image
    JotForm Support

    Answered by Kiran on December 08, 2016 at 04:51 PM

    Thanks. Please allow us some time to replicate the issue at our end by creating the custom fields. We'll get back to you once we have any useful information in this regard. 

    Thank you for your patience. 

  • Profile Image
    JotForm Support

    Answered by Kiran on December 15, 2016 at 07:23 AM

    We are sorry for the delay. I have tested the clone of your JotForm by adding some of the custom fields in Salesforce Contact. As I submit the form, I see that the contact information is being sent to Salesforce without any issue.

    Could you try cloning the form to your account and then integrate Salesforce to see if that works? Also, while integrating Salesforce it would be helpful to isolate the issue if you can map a group of fields and test it rather mapping all the fields at a time. 

    Let us know if you need any further assistance. We will be happy to assist.  

  • Profile Image

    Answered by SPARKDallas on December 27, 2016 at 03:01 PM
  • Profile Image

    Answered by SPARKDallas on December 27, 2016 at 03:06 PM

    I have tried cloning the form and re-doing the integration but it's still the same fields that show up. I event tried a different Salesforce user's login credentials and the same fields showed for both integrations. The fields that appear are mapping correctly, but not all of the fields I need are showing up in jotform. 

  • Profile Image
    JotForm Support

    Answered by jonathan on December 27, 2016 at 06:39 PM

    Can you please tell us which of the mapped fields on your form https://form.jotform.com/63395662161156 were not having results in your Salesforce?

     

    We will check more once we have a better understanding of the issue.

    Thanks.

  • Profile Image

    Answered by EKettlewell on December 28, 2016 at 05:34 PM

    All of the currently mapped fields are correctly mapping to Salesforce. The issue is that there are additional fields I would like to map from Jotform to Salesforce, but the additional fields are not showing as a mapping option. In the answer by Kiran above, it shows he was successful in mapping fields such as: "Adult #2 Name" and "Current Membership Level" in his clone of my form. I have yet to have the same success in mapping these fields from my JotForm to Salesforce. They do not show up in the dropdown list of available Salesforce fields to choose from. 

  • Profile Image
    JotForm Support

    Answered by Mike_G on December 28, 2016 at 07:23 PM

    Please allow me some time to further check and try to reproduce the issue you're having. I will also contact Kiran to check with him if there are any other steps he took as to why he was able to select the mentioned custom fields from his Salesforce during the integration with his form.

    I will get back to you as soon as possible.

    Thank you.

  • Profile Image
    JotForm Support

    Answered by Mike_G on December 29, 2016 at 07:14 PM

    I was able to reproduce the issue you're having and I believe I have found the solution to it.

    I would suggest you inspect the "Visible" option(s) checklist for your custom fields and make sure that the "System Administrator" option is (checked) set to visible for each custom field you have.

    Please see the following images below for the detailed instructions on how you can check it.

    First, click "Set Up" and from the side panel under "Build" expand "Customize" and select "Contact" then "Fields"

    Then, under the "Contact Custom Fields & Relationships", click the edit link of the custom field that you would like to inspect.

    After that, you will be able to view the "Edit Contact Custom Field", "Custom Field Definition Edit". Please click the "Change Field Type" button.

    Skip Step 1: Choose the field type

    Skip Step 2: Enter the details

    Then, on Step 3: Establish field-level security, make sure that the "System Administrator" option is checked.

    Click Save after you had verified that it is checked.

    Then, go to your form and on the Salesforce integration wizard, select "Account" first as a list and then select "Contact" again after so it will reload the available custom fields from your Salesforce account.

    I hope this helps and solves the issue you're having. If you have other questions regarding this, please feel free to let us know.

    Thank you.