Conditions don't appear to be working

  • Profile Image
    Deborah.Miller
    Asked on December 07, 2016 at 08:31 PM

    Hi, I noticed that 2 of my conditions don't appear to have worked just now when a form was submitted. The one that defines the type and the IRSO contact for this form. They were working up to the last submission.

     

  • Profile Image
    Rose
    Answered on December 08, 2016 at 02:24 AM

    Thank you for contacting us. 

    It took a while to understand what the issue is exactly. You have a lot of conditions for your fields and you have hidden fields on your form, too. As I understood from your post, your following conditions did not work for the submission with ID 356967440979351600. 

    Condition for the field 'IRSO' which is a hidden field

     Condition for the field 'type' which is a hidden field


    When I checked the mentioned submission data, these two fields are empty even though they should have been as  Lary Guo & Hire Only. That's why, you were thinking that your condition does not work. I checked your condition but I did not find anything effecting these fields. 

    As a second step, I cloned your form to my side and just filled the cloned form as the same data as that submission. I can confirm that conditions worked as they should work. I also did the same thing on your form, just sent a test submission and conditions worked properly on your side,too. 

    You can check my test submission on your submission page.  ( Submission ID : 356989690850132969) 

    All in all, this issue could be a temporary one and seems that your condition works fine now.  Could you please follow up this issue and let us know if you encounter the same problem again. Then, we will escalate this subject to our developers for more investigations. 

  • Profile Image
    irfanmoosani
    Answered on December 08, 2016 at 02:28 AM

    I tested the form and I could not replicate the issue.

    This is the Submission output I see when I submit the form

    The conditions appears to be working fine.

    Let me know if we are not on the same page.

  • Profile Image
    Deborah.Miller
    Answered on December 08, 2016 at 12:12 PM

    Thank you for looking into it - the test cases I ran this morning show that it appears to be working again as well so it looks like it was just a glitch on that one submission.