My form loads very slow on mobile devices

  • Profile Image
    supremec
    Asked on December 08, 2016 at 05:56 AM
    Im also experiencing very slow loading times (sometimes up to 45 secs) on mobile with the form. Would you know why this might be happening?
  • Profile Image
    Rose
    Answered on December 08, 2016 at 06:35 AM

    There are so many reasons regarding slow loading time issue. It could be due to internet speed, memory load, cache issue, network issue, etc. It also depends on how many conditions you have and how many widgets you are using on your form. There could be also some other thinks which effect your form loading time.  

    I tested your form on my android device and loading time last at least around 10 secs. Could you please let us know that you have this issue on which mobile devices? I mean phone details. 

    I also clear your form caches to see if this makes any differences. 

    Please also note that you can clear your form caches on your own. You just need to go to your Account > Setting and click Clear Cashe button

    Waiting for your feedbacks. 

  • Profile Image
    supremec
    Answered on December 08, 2016 at 07:51 AM

    Hi Rose,

     

    Thanks for the quick reply. I've tried clearing the cache but that didn't fix the problem unfortunately.

    We tried loading the form on two different phones and on separate connections. The results were:

    Iphone 6 IOS 10.1.1 and safari load time 21 secs approx. On Wifi.

    Galaxy S7 6.0.1 Chrome 34 secs approx. on 4G

    Thanks

    Ross

  • Profile Image
    owen
    Answered on December 08, 2016 at 08:26 AM

    Hi Ross,

    I have tried to load your form on several devices including a Windows Phone and an iPhone 7. However, I could not reproduce the issue. It did not take more than 5 seconds to load your form both on wireless and 4G. It may have taken just a little longer on 4G but it was nothing of importance. 

    When I cloned your form I noticed that you uploaded images to create breaks on your form. This definitely increases the loading time. Please remove the images and try loading your form again. Let us know about the loading time in this case. 

    Thank you