What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Hover text not working is not working on some of the fields?

    Asked by mysteria1 on December 11, 2010 at 10:22 PM

    I created a form with hover text, but it only shows on two of the fields. Can anyone suggest what is happening here. The form is here http://www.tanen.com.au/Contact-Us.html and it is only the date fields that show the hover text even though all have hover text entered.

  • Profile Image
    JotForm Founder

    Answered by aytekin on December 13, 2010 at 08:48 AM

    I added this to our bug list. Thanks for reporting it.

  • Profile Image

    Answered by williambuyshousesfast on December 14, 2010 at 12:58 PM

    Yes, I thought I was the only one who noticed this little bug. On my form there are only 2-3 fields with working Hover text. 

  • Profile Image

    Answered by annedigby on January 08, 2011 at 11:38 PM

    I've only recently created my form and most of the hover texts aren't working - has this bug been fixed yet?

  • Profile Image
    JotForm Founder

    Answered by aytekin on January 10, 2011 at 09:25 AM

    No, if it was fixed we would have updated this page. You should probably use the "Sub label" feature instead for them.

  • Profile Image
    JotForm Founder

    Answered by aytekin on January 14, 2011 at 08:03 AM

    I checked this form and all hover text work fine. So, this issue is already resolved. If you have a form that has some hover text not working, please post it.  

  • Profile Image

    Answered by brendabohl on January 17, 2011 at 01:09 PM

    Hover text is not working for me on the survey slider feature.

  • Profile Image

    Answered by cfranson on January 17, 2011 at 02:31 PM

    my hover text is unpredictable.  Sometimes it works fine other times it's too far to the right of the form and half of it is cut off.  If I refresh the page, it suddenly works fine.

  • Profile Image

    Answered by brendabohl on January 17, 2011 at 02:39 PM

    Hmm...I'll have to try that.  Unfortunately, whoever is filling the form out, won't know to do that.

  • Profile Image
    JotForm Founder

    Answered by aytekin on January 18, 2011 at 08:57 AM

    Please provide more details so we can help you. 

    1. List of URLs of the forms that has hover problems

    2. List of questions which does not show the hover text

    3. Browser Type and Version

     

    Thank you! 

  • Profile Image

    Answered by cfranson on January 18, 2011 at 09:05 AM

    I'm using Safari 5.0.3

    http://www.outlawsalsa.com/OutlawSalsa/Subscribe.html

    Fields: Preferred Outlaw Nickname and Zip Code.

    When it happens it will always be to both fields at the same time.  Then usually, if I reload the page it will correct itself.

    Also, sometimes they will be aligned far to the left, on top of the field and other times way off to the right and sometimes only half showing, like some margin is cutting it in two.

    Thanks

  • Profile Image

    Answered by serkan on January 18, 2011 at 09:54 AM

    I think I've understood this problem. Our hover mechanism is a bit inconsistent. For some fields hover pops when the mouse is over the field and for some fields it pops when fields get clicked. I think this is causing confusion, it should work on mouseover for all fields. I'll add this to our bug list and will fix it soon.

  • Profile Image

    Answered by brendabohl on January 19, 2011 at 09:15 AM

    Thank you.  For now, I've just removed the hover text from my form and will wait for the fix.

  • Profile Image

    Answered by markashton on January 19, 2011 at 05:51 PM

    Most respectfully mean't:

    I posted this thread in May last year. Take a look at this:
    http://www.jotform.com/answers/2096

    Then in early June I posted this:
    http://www.jotform.com/answers/2388

    I've been waiting for this fix for 6 months. It's already on your bug list. What happened?

    Regards Mark

  • Profile Image
    JotForm Founder

    Answered by aytekin on January 20, 2011 at 07:12 AM

    It is still in our bug list. We have hundreds of low priority bugs. This is one of them. We will update here when we have a fix. 

  • Profile Image

    Answered by serkan on January 31, 2011 at 03:59 AM

    I've fixed all hover texts to be appeared on mouseover. This should resolve your problem until we come up with a better solution.

  • Profile Image

    Answered by brendabohl on February 01, 2011 at 10:09 AM

    Thank you!!  It's much appreciated.