Form Builder v4: FreshBooks Integration

  • Profile Image
    deltacountyfair
    Asked on December 13, 2016 at 10:33 AM
    On another note on the Version 4 Beta, going to Settings and the integrations to integrate with Freshbooks I can see all the apps but it won’t let me click on anything. I can click but it won’t open any windows or respond. Unsure if my connection is slow or if there is a bug in version 4 beta.
    Thanks,
    Kris
  • Profile Image
    Boris
    Answered on December 13, 2016 at 12:01 PM

    Thank you for reporting this, Kris. I have checked the issue on several browsers, and I was able to reproduce it. The FreshBooks integration wizard is not running inside our Form Builder v4:

    Let me forward this issue to our developers as a bug report. Our v4 is still a work in progress, and as such there are bound to be issues like this happening sometimes, but we are actively working on resolving them and improving the system.

    In the meantime while this is being worked on, I would recommend opening your form in our Form Builder v3 to set up your FreshBooks integration. When using v3, the integration wizard runs correctly:

    Thank you.

  • Profile Image
    Scott
    Answered on December 14, 2016 at 07:30 AM

    Hey deltacountyfair,

    I was informed by our developers that FreshBooks integration is not planned to be developed for V4 at this moment. (I also asked them to get the FreshBooks logo out of the V4 integration list)

    I've assigned this ticket as a feature request. If this integration will be available for V4, you can hear from us through this thread.

    Cheers.

  • Profile Image
    balletsutton
    Answered on May 18, 2017 at 03:23 PM

    Hi @Scott - does that mean that if we can still switch the form to use Version 3 and use the Freshbooks integration?

    If so, what happens if we later switch the account to v4?

    thanks

  • Profile Image
    Welvin
    Answered on May 18, 2017 at 04:29 PM

    Yes, that is correct. You can use Freshbooks on Version 3 builder.

    You need to keep the version 3 builder if you wish the Freshbooks to work properly. Otherwise, the integration will be removed in the form. Worst case, your form might not work due do the broken integration.