Thank You Redirect Conditions Not Working

  • Profile Image
    devincornell
    Asked on December 22, 2016 at 02:56 PM

    I had this working last night and now it's not.

     

    I have a condition to redirect to another from based on the field payment method. Upon submitting it now goes to a blank page with the incorrect address in the browser address bar.

     

    Please help.

     

    https://www.jotform.com//?formID=62321738845258

  • Profile Image
    jonathan
    Answered on December 22, 2016 at 03:31 PM

    I did a test submission using your form https://www.jotform.ca/form/62321738845258

    And on submission it successfully redirected to the other form  https://form.jotform.com/63555056171253 according to the condition rules.

    Here is the video of my test

     

    It seems the Thank You Redirect condition logic on your form is working as it should.

     

    Can you please test again. Let us know if still not working on your side.

    Thanks.

     

     

     

     

  • Profile Image
    devincornell
    Answered on December 22, 2016 at 08:25 PM

    Thanks for the quick response. Still happening on my end, with laptop and iPhone.

     

    This is the address I get sent to: https://submit.jotform.ca/submit/62321738845258/

  • Profile Image
    Welvin
    Answered on December 22, 2016 at 10:30 PM

    I cannot replicate the problem. The submit URL is correct, but that should suppose to redirect you to the thank you conditions, should not take long. Please try clearing your browser cache. This should help.