What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Forms do not appear in Internet Explorer

    Asked by mouseunlimited on May 23, 2012 at 10:41 PM

    I've designed secure and non-secure forms and have embedded both on our site.  The forms display fine in Chrome, but not in IE 9.

    This form is a non-secure form, and on a page not encrypted by our own SSL, so there should be no issues with regards to secure vs non-secure.

    Please tell me how to get all forms, both secure and non-secure, to display in IE. It's actually most important that we be able to use SSL forms, as that's what we'll use the most, to collect credit card info.

    Page URL:
    http://www.mouseunlimited.com/contact

  • Profile Image
    JotForm Support

    Answered by idarktech on May 23, 2012 at 11:17 PM

    Hi,

    This may be due to a conflicting codes within your website, try re-embedding your form using iframe code. Since form is called in iframe, it wont conflict anything on your page.

    Follow this guide: How to get your Form's Iframe Code

    Hope this helps. Let us know if the problem still persist after that. Thanks!

  • Profile Image

    Answered by mouseunlimited on May 23, 2012 at 11:21 PM

    I just placed the iframe code into the page and now it displays a larger area for the form, but still does not display the form.

  • Profile Image
    JotForm Support

    Answered by idarktech on May 23, 2012 at 11:39 PM

    Hi,

    Thanks for your fast reply.

    Could you please try to remove the second html table code where you've added your code? This may be the problem.

    Try and let us know if this doesn't help. Thanks!

  • Profile Image

    Answered by mouseunlimited on May 24, 2012 at 09:03 PM

    I removed the TABLE tags and it allowed the non-secure form to display. Haven't gone beyond that. However, it's not displaying my custom submit button image.  It's continuing to insert the relative path, even though I've put the full path into the jotform builder.

    I've cleared my cache in IE and Chrome, and every time I reload the page, the path is trying to reference the file relative to http://forum.jotform.us instead of my domain.

    How do I force it to find the image on my server while using iframes?

    I also tried it without iframes, which I would prefer, but then the reCaptcha doesn't display in IE. Very strange.

    Thanks for your help.

  • Profile Image
    JotForm Support

    Answered by abajan on May 24, 2012 at 09:18 PM

    Hi

    Changing the URL in the iFrame from http://form.jotform.us/form/21056900700138 to http://www.jotform.us/form/21056900700138 should correct the non display of the submit button.

  • Profile Image

    Answered by mouseunlimited on May 24, 2012 at 09:37 PM

    That worked abajan, thanks!

    Now, Semester 2 work.  Go to https://www.mouseunlimited.com/payment

    That's using a Secure JotForm, and it's on one of my SSL protected pages.  Relative link images are not appearing.  What can I change in the iframe URL that will allow the images to dislay, but will not sacrifice my secure transmisson to JotForm?  This form collects Credit Card info.

    Thanks!

    EDIT: Nevermind. Just pasted the full URL into the form builder and it worked by itself on the secure forms!

  • Profile Image
    JotForm Support

    Answered by idarktech on May 24, 2012 at 10:01 PM

    Hi,

    Can you please recheck the form on your site? It's working fine here, images displays properly. Be sure to clear your browsers cache first. :)

    Let us know if the problem still persist on your end. Thanks!

  • Profile Image

    Answered by mouseunlimited on May 24, 2012 at 10:06 PM

    @idarktech

    You were probably looking after I fixed it and before I EDITED my last post above. I plugged in the full paths in the form builder and it worked.

    Everything is A-OK!

    Thanks!

  • Profile Image
    JotForm Support

    Answered by abajan on May 24, 2012 at 10:08 PM

    On behalf of my colleague, you're quite welcome.

    Cheers

  • Profile Image

    Answered by mouseunlimited on May 24, 2012 at 10:10 PM

    To both of you....great support. I'm proud to have purchased the software and look forward to finally having a form system that does everything I need. I've been looking for years!

  • Profile Image
    JotForm Support

    Answered by idarktech on May 24, 2012 at 10:22 PM

    We're happy to hear it,  mouseunlimited.

    Thanks for your good feedback. Have a pleasant day!