JotForm not generating Leads in Salesforce

  • Profile Image
    SLUCookBusiness
    Asked on January 04, 2017 at 09:39 PM

    We are attempting to integrate this for to create leads (or prospects, we're using the higher ed pack) in Salesforce. I've ran a few tests and none of the tests are making its way to Salesforce. All of the fields needed are mapped, and Jotform says that the integration is up and running. We have the same integration running for Mailchimp and its working like a charm. 

  • Profile Image
    EltonCris
    Answered on January 05, 2017 at 02:23 AM

    Hi,

    Have you tried following this guide? https://www.jotform.com/help/271-Flexible-Data-Integration-With-Salesforce

    Please make sure that the recipient of your radio and checkboxes are textbox fields in your Salesforce form.

    I tested the cloned version of your form, mapped some of the basic fields (name, email and company) and they are sent to Salesforce.

     

     

    In salesforce:

    Please try to re-integrate your form with Salesforce and apply the above suggestions. As much as possible,  make sure that the recipient fields are text boxes.

    Example:

    Full Name -> Name field in Salesforce

    Email -> Email field in Zoho

    Radio button > Textbox field in Zoho

    Checkbox > Textbox field in Zoho

    If you are passing checkbox to checkbox field, make sure the recipient checkbox has the same options in the checkbox field from JotForm.

    Let us know if the issue still persists after this.

  • Profile Image
    SLUCookBusiness
    Answered on January 05, 2017 at 01:11 PM

    Cool Cool. Just to make sure its not any of that I made it so that it just syncs name, email, and company and I'm still not getting it to move to salesforce. Is there an issue with the higher ed pack we have installed?

  • Profile Image
    Jan
    Answered on January 05, 2017 at 02:49 PM

    I apologize but I'm not familiar with the "Higher Ed pack" plugin or add-on in SalesForce. The function of the integration is to transfer the data from the JotForm form to your SalesForce database. 

    Do you have a SalesForce account that doesn't have "Higher Ed pack"? You can try using that just to check if the issue is with the "Higher Ed pack" or not. Based on the test made by my colleague EltonCris, it is working properly.

    Hope that helps. Thank you.