Uploaded images are not showing

  • Profile Image
    mgcaledonian13
    Asked on January 08, 2017 at 03:27 AM

    Uploaded images are not showing in the viewer, in fact they have disappeared as they were there a couple of weeks ago.
    It is just the image that is not showing all the relevant text is there from the user's input, it does show in the Submissions, see screen shot.

    To be honest I cannot remember how this was done, I had a look through my old threads as I know I had trouble when I originally set it up

    Have I messed it up or has something gone wrong ?

     

     

  • Profile Image
    liyam
    Answered on January 08, 2017 at 08:23 AM

    Hello mgcaledonian13,

    Can you try editing again your form on views.jotform.io and see to it that you have added the template variable on your list view editor?

    Here's an example:

    The same case for the content view

    Once done complete the wizard and it should show up the image on the page.

    If you have questions, please let us know.

    Thanks.

  • Profile Image
    mgcaledonian13
    Answered on January 08, 2017 at 06:58 PM

    Oh! Yes I remember doing this way back. It is the most non intuitive app I have come across someone needs to rebuild this, it is atrociously bad. I am not that sure I want to go there again.
    The tutorial video is so fast it is hard to follow, in fact impossible.

    Is it in the widgets list if so what is it called?

    The real question is why did it stop working in the first place?

    You guys have always got a 100 out 100 from me but this reply scores 10 out of 100 and the app scores a big fat 0 out of 100.

    Disappointed very Disappointed

    Willy Scott

     

  • Profile Image
    Helen
    Answered on January 09, 2017 at 03:26 AM

    Hi Willy,

    Thank you for contacting us.

    The tutorial video is so fast it is hard to follow, in fact impossible.

    Sorry for this inconvenience. You can add template variable, just follow these steps:

    1. Just click "Add your Website Now" button to start.

    2. Click "Choose your form" button for choosing your form that you want.

    3. Select your form from Form Picker and just click "Continue".

    4. After that, you can see this page. Just click "Next".

    5. You can add you field upload field to your List View at Create List View page.Then click "Save Templates".

    6.You can add you field upload field to your Submission View at Create Submission View page.Then click "Save Templates". And click "Next".

    7. Here is you iframe code that you must add to your website. Just copy it and paste it to your website's source code.

    Done! I have checked your website that you shared and realized that your all images were shown properly. However, your four submissions image shown like "no image". As you can see:

    I have checked these images. They uploaded like that "No image" image. The submitters submitted it like they shown. So, everything works properly on your site.

    If you have any questions or issue, feel free contact us.

  • Profile Image
    mgcaledonian13
    Answered on January 09, 2017 at 05:41 AM

    Helen

    Thanks for the help but I revisted this "thing" again and spotted the error, the wrong field name was inserted why I do not know.

    Anyway it is now working fine but, I still maintain it is the most difficult thing to get right first time. What are all the red lines that keep appearing, there is no explanation as what these are or do with a bit trial and error I got the image in the right place, just and no more.

    By the time you had looked it I had fixed it myself so that is why the Images appeared on the page OK.

    I still maintain that it should be re built to make it easier to use and with a more detailed explanation.
    Your Slogan is Easiest Form Builder so that is what this is NOT

    Willy Scott

  • Profile Image
    owen
    Answered on January 09, 2017 at 07:13 AM

    Hi Willy, 

    All our applications have been reviewed recently and the problems with them have been reported. They will be fixed as soon as possible. I agree with you on the red lines that keep appearing, they do not seem to be functional at all. I hope this one will be stabilized as well. 

    We are sorry for the inconvenience that is caused by this. Thank you for your participation in making JotForm more useful. 

    Please contact us again if you need any further assistance. 

  • Profile Image
    owen
    Answered on January 09, 2017 at 07:23 AM

    To update my latest response, the red lines are actually functional but they are not too easy to catch. When you press the "Enter" by the end of these lines, a new line is created so that you can customize the layout. I just wanted to let you know about this. 

    Have a great day :)

  • Profile Image
    mgcaledonian13
    Answered on January 09, 2017 at 11:41 AM

    Owen

    Thanks for that explanation ??

    It would be good if you had just a blank Canvas and were able to drop the Field name in anywhere and add text as required, it seems to me to be more complicated than it needs to be.

    At first the image was nearly a thumbnail, but when I moved it to another position above a red line it came in as full size, that is where an explanation is required.

    Willy (Moaner) Scott 

  • Profile Image
    BDAVID
    Answered on January 09, 2017 at 02:18 PM

    That is how the app is designed, the image is shown as a thumbnail in it's default position, if you moved the image to another position, it will be shown in full size. I have forwarded this to our back end team. so it can be revised.

    On regards of the app itself, if you feel it is not an intuitive app, you are welcome to leave a feedback about it:

  • Profile Image
    BDAVID
    Answered on January 09, 2017 at 02:28 PM

    You will be notified in the following thread: https://www.jotform.com/answers/1029517, if there is any updates on the image field positioning.