Configurable List: Mailto attribute doesn't work static text

  • Profile Image
    quikval
    Asked on January 09, 2017 at 06:17 PM

    I wish to add <a href></a> html to a static item that is inside a configurable list item.  I don't seem to be able to get the widget's cooperation, please help?

  • Profile Image
    Kiran
    Answered on January 09, 2017 at 10:31 PM

    I understand that you want to add a static text with link to the configurable list. You may set the static text using the option static in the configurable list. Please see the screenshot below:

    This should be displaying the link on the form as below:

    Please refer to the guide below that can help you with setting up the configurable list widget.

    https://www.jotform.com/help/282-How-to-Set-Up-the-Configurable-List-Widget

    Hope this information helps! 

  • Profile Image
    quikval
    Answered on January 10, 2017 at 12:37 PM

    That doesn't seem to work for inserting "mailto:" commands, however.  Here is the code I've been trying to get to work... maybe I'm just needing a set of eyes to review it...? (on my code, the missing label is intentional.)

     : static : <i>Please <a target="_blank" href="mailto:info@noname.com"?subject=Valuation request: irregular accounting cycle>contact QuikVal</a> if accounting cycle is not monthly on month-end</i>

  • Profile Image
    Jim_R
    Answered on January 10, 2017 at 02:08 PM

    You're correct, it appears the widget strips off the HTML tag if it uses mailto as the link.

    I'm assuming this was by design for security reasons but to be sure, I've escalated this to our Devs so they can confirm.

    I won't be able to give you any timeframe, but rest assured, we'll keep you apprised on this same thread if/when there's an update.

  • Profile Image
    quikval
    Answered on January 11, 2017 at 12:48 PM

    Thanks for investigating, I look forward to the feature revision!