What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Forms using Google Web Fonts are producing errors and loading quite slow

    Asked by alltor on January 12, 2017 at 10:43 AM

    Hello,

    I have some issues with a simple form I have embedded on a webpage I created with Adobe Muse.

    I first used the javascript approach, just selecting Adobe Muse when "publishing", but this only worked on the site's original size. When it got to the first break point the form just disappeared. Other than that it was quick and worked nicely.

    I see you quite often recommend iframe in similar cases, so I tried that instead. And it works! Only... there is a weird problem where a few of the images on the same page are loading very very slowly. Like 20-30 seconds slower than before. The header image and google maps widget and the form in question loads instantly for some reason.

    Have you got any clues as to why it does this?

     

    Thanks in advance!

    /Forsberg

    Page URL:
    http://alltor.se/inbrottslarm.html

  • Profile Image
    JotForm Support

    Answered by david on January 12, 2017 at 12:39 PM

    I checked your page and I can see what you are referring to.  The error I am seeing is associated with using Maven Pro webfont in your form being blocked. 

    Try using one of the system fonts instead of one of the Google fonts:

  • Profile Image
    JotForm Support

    Answered by david on January 12, 2017 at 03:51 PM

    This should now be fixed.  If the issue persists, let us know and we will be happy to have another look.

  • Profile Image

    Answered by alltor on January 13, 2017 at 03:46 AM

    Oh I see! Yes this fixed the problem, thank you!

     

    Issue resolved.