Empty fields are showing up in the email although hide empty emails is enabled.

  • Profile Image
    pdxconnect
    Asked on January 15, 2017 at 09:31 PM

    Both notification and autoresponder emails on submissions are set to Hide Empty Fields, yet, empty fields display in these emails.

  • Profile Image
    candy
    Answered on January 16, 2017 at 02:39 AM

    Hello,

    I have checked your forms and email configurations.

    I have seen that your email contents have been set with wrong form fields IDs. That is the reason of why they came empty.

    Please check the screenshot below of your email content:

    The field IDs inside the Red Boxes are wrong ones. The field IDs inside the Blue Circles are right ones instead.

    You can delete the wrong ones changing them clicking on the "Form Fields" as you can see the screenshot below:

    You need to detect which fields come empty and change them as you can see the screenshot above.

    Or, if you find this solution very challenging, you can just delete the notification and autoresponder emails and add to your form again. The fields will be created automatically.

    After changing, you should receive the emails as the following example screenshot below of the notification email:

    For further detailed information, please check the following document: https://www.jotform.com/help/30-Explanation-of-Email-Notification-and-Autoresponder-Settings 

    Please try. If you need further assistance, let us know.

    Thanks in advance.

  • Profile Image
    pdxconnect
    Answered on January 28, 2017 at 01:15 PM

    I deleted both notification and autoresponder email and recreated.  The result is the same.  The blank fields displays in both types of emails.

    Also, when I click the form field, the field number in the pick list matches what is already on the form

  • Profile Image
    Nik_C
    Answered on January 28, 2017 at 04:13 PM

    I cloned and tested your form and I was able to replicate the problem. The empty fields were appearing. But when I removed the Notifier and Autoresponder it worked fine. So I'm not sure if you did that as well. Here is my clone of your form, feel free to test and clone: https://www.jotformpro.com/form/70275988461973

    If you are still facing the same problem please let us know.

    Thank you!

  • Profile Image
    pdxconnect
    Answered on January 28, 2017 at 07:10 PM

    So I should not use the Notification and Autoresponder email feature?

     

    Earlier today I deleted both the Notification and Autoreponder, then recreated them.  But the empty fields still showed up.  

  • Profile Image
    Chriistian
    Answered on January 28, 2017 at 11:12 PM

    Can you try to create a new notification email on your form without changing anything on the notification setup and test if the issue reported also occur on the default email notification setup?

    If the issue still persists even on the default email notification setup, can you try to clone your form and setup again/re-create the notification and/or autoresponder on the cloned form and see if the issue is fixed on the cloned form? To clone a form, just follow the instructions provided in this article: How to Clone an Existing Form from a URL.

  • Profile Image
    pdxconnect
    Answered on January 29, 2017 at 02:45 PM
    When I enter the form's URL I receive the following error:
    ...
  • Profile Image
    Welvin
    Answered on January 29, 2017 at 05:07 PM

    Please note that this forum can't accept email attachments. Please access this thread and use the image field to upload. But please try this URL: http://www.jotformpro.com/form/70275988461973 or https://www.jotform.com/70275988461973.

    As for the original problem, you seem to have modified your notification and autoresponder emails. Please keep the tables intact including the heading/title/rows/columns, no modifications. Please re-create the emails once again. 

     

  • Profile Image
    pdxconnect
    Answered on January 29, 2017 at 05:39 PM

    The emails from the cloned form worked as desired when I just left the default.

    If I'm reading your response correctly, I should NOT modify the table to remove things like "You can edit this submission and view all your submissions easily." or update the title are of the form.  

    Is that correct?

    By the way, thank you all for your quick responses!  JotForm has amazing customer service!

     

  • Profile Image
    Chriistian
    Answered on January 29, 2017 at 08:21 PM

    That is correct. When using the default notification and autoresponder, empty fields will be hidden without any issue. However, if the table is modified, then the "hide empty fields" feature will not work properly.

    If you need further assistance, please let us know.
    Regards.