I'm stuck at "please wait" when making a submission

  • Profile Image
    harropdan
    Asked on January 20, 2017 at 05:21 AM
    I'm still getting "Please wait" too?
  • Profile Image
    owen
    Answered on January 20, 2017 at 06:11 AM

    Hi,

    I can see that your form has a Stripe integration. We had a temporary issue with Stripe but now it has been fixed. I have cleared your form caches. Your form should be working as expected as of now. Please check your form and let us know if the issue still persists. 

    Do contact us whenever you need assistance. We are glad to be helping you. 

  • Profile Image
    harropdan
    Answered on January 20, 2017 at 06:45 AM
    unfort I am still getting the same problem:
    can you try to make a min payment here e.g $0.50 NZD?
    http://www.dwellwaiheke.co.nz/oneroa-hq-gift-voucher/
    ...
  • Profile Image
    harropdan
    Answered on January 20, 2017 at 06:45 AM
    is the issue due to me not having an SSL cert?
    ...
  • Profile Image
    owen
    Answered on January 20, 2017 at 07:07 AM

    Oh, I see. I should've asked you whether your form was embedded on a website or not. This issue of yours is not related to SSL certificate. It is related to your embed option. It seems like there is a script conflict on your page.

    What you should do is to embed your form with the iFrame method. Please see how you can do it on this guide of ours:

    https://www.jotform.com/help/148-Getting-the-form-iFrame-code

    Try the iFrame method and let us know if the issue still persists. 

    Thank you for your update!