What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Please ensure you test V4 properly before releasing it - Cannot change text or headings in version 4

    Asked by dorsetholidaylets on January 22, 2017 at 07:26 AM

    I have forms created in the old version which I cannot change headings or text fields Using V4. On the heading field it briefly shows the options to change or delete but then vanishes, while for text fields it shows nothing, it just blinks when you click on it.

    If I add a text field using V4 it does not allow you to change it or delete it so I have now a text field with "Double click to edit this text" that I cannot change or delete on a form I am using. Not good!

    This is the 2nd error I have found on V4 with just a few minutes testing which indicates it has not been tested very well. Businesses depend upon your software and they need it to be properly tested before being released. With just a few days before you plan to release it it does not look good.

    You should not expect your users to test your products for you. Sorry to be so negative but.....

     

    Please delete the  text "Double click to edit this text" on the form below

     

    Regards

     

    David

    Page URL:
    https://form.jotform.com/60044950936962

  • Profile Image
    JotForm Support

    Answered by liyam on January 22, 2017 at 09:16 AM

    Hello,

    For changing texts, you can click on the edit text button found on the right part of the field.

    A similar case works well when clicking properties on header elements, which on this one opens the properties window on the right panel of the builder

     

    Please try reloading the page again. If it's working right after, the problem you encountered may be a minor glitch or probably there was an error which has already been fixed.

    While we have not yet officially launched the v4 of the builder, we allow users to get a look-see of the version prior to launch. But if you do not wish to use the V4 of the form builder yet, you can revert back to V3 as your default builder by going to your Account settings page

    If you have questions, please let us know.

    Thanks.

  • Profile Image

    Answered by dorsetholidaylets on January 22, 2017 at 09:46 AM

    There is no option to click on the edit button. None of those Icons appear. Please read my previous question above. I am using Google Chrome so please test using this and you should see what I mean.

  • Profile Image
    JotForm Support

    Answered by liyam on January 22, 2017 at 12:02 PM

    Hello,

    I did tests following the screenshot when I responded to you earlier. This is how it functions on my end under Google Chrome:

    Can you confirm that this does not happen on your browser?

    Thanks.

  • Profile Image

    Answered by dorsetholidaylets on January 22, 2017 at 12:58 PM

    I know how your system is supposed to work, but for text fields and Headings there is no way I can bring up the 3 icons to edit/delete or properties. Likewise to make a change to one of the other fields, you have to click on the field name to get the 3 icons and as there is no field description for text and headings there is nothing to click on which is the problem. If I send you a screen image there is nothing to see as clicking on text fields does not display anything,

  • Profile Image
    JotForm Support

    Answered by liyam on January 22, 2017 at 02:44 PM

    I have tried loading the page a number of times but I could not replicate the problem. As you can see on the screenshots and animated gif I made (they were actual tests) the icons appear fine and can be clicked.

    Have you tried clearing your browser's cache to see if it's a cache-related bug? While at this, I will also do more tests for possible scenarios to replicate the issue.