Calculation not working in V4 form builder?

  • Profile Image
    stormingrobots
    Asked on January 24, 2017 at 01:30 AM

    I just checked a few of my calculation fields.. None of them work work..  I have yet checked all of them, but they were working before.. 

     

    https://form.jotform.com/70208611384148

     

    The interface all the sudden changed to something different.  Perhaps you are in the middle of uploading changes!?    I have really serious issues with the building interface now. Most of the calculation fields not even working.  Hope this is just because you are updating the system?!   I have about about 20 hours on this form. Hope it will revive itself  in the morning :-( 

     

    O no!  The header even disappeared!!!

  • Profile Image
    stormingrobots
    Answered on January 24, 2017 at 02:05 AM

    Ok.. now the calculation fields are back to normal, except the it does not take "$" anymore. With that in the calculation, no result shows up.

     Are you in the middle of changing your interface?  It is very inconvenient comparing to the previous one. The top menu is not longer there, except the 3 big buttons of "build", "setting" and "publish".  Ugh!  

  • Profile Image
    Charlie
    Answered on January 24, 2017 at 03:49 AM

    Hi,

    I can't seem to replicate the problem, could you please provide us specific details on how we can recreate the issue? 

    The calculation will not be triggered while editing the form, you need to view the form itself. Here's a screencast of me filling out your form: 

    The calculation seems to be happening, but I am not familiar on how they actually work so it would help us a lot if you could provide us more details. What fields are not calculation correctly?

     

    If you are having issues with the new Version 4 form builder, you can switch back to V3 to edit or update your form. To switch back, you can check the screenshot below:

     

    The Version 4 is still in Beta so it is possible that users might encounter problems, but we will appreciate if you could provide the details so that we can have it forwarded to our developers for fixing. 

    Apologies for the inconvenience.