Form is cut-off in Xara platform

  • Profile Image
    Rainbowcolours
    Asked on January 24, 2017 at 10:50 PM

    Also I'm having lots of problems making the forms work in Xara webdesigner 11 premium.

    If I use the Xara platform only half the form shows.

    If I click on embed or Source code or iFrame it sometimes works, but often only part of the form is there or the captcha does not work.

    Of course this could be a problem with Xara.

  • Profile Image
    jonathan
    Answered on January 24, 2017 at 10:53 PM

    Please share to us the URL of your Xara website where the form was used. It will help us in determining what could be the issue if we can check it on the actual form used.

    Thanks.

  • Profile Image
    Rainbowcolours
    Answered on January 26, 2017 at 03:47 PM

    The URL is www.canvasartprints.co.nz

    If I use the Xara platform it never works, only half the form is there.

    On the desktop source code or iFrame usually works, but I tried again today and only half the form is there or the captcha does not work.

    So I just clicked on embed and that's how it is on the website now and it works on the desktop.

    I tried to copy that and paste it into the mobile version and it does not work.

    On mobile iFrame seems to be the best but not the whole form is there, however if I fill in the form and upload a picture the rest of the form appears, so it can be used.

    If I click on Contact there is no form until I refresh the page, then most of the form appears, but not all of it.

    My other website www.photorestorations.co.nz work.

    Kind regards

    John

  • Profile Image
    Chriistian
    Answered on January 26, 2017 at 05:17 PM

    Hi there,

    I was not able to find a form in your site's home page so I just assumed you are referring to the form in this page: http://www.canvasartprints.co.nz/contact.htm. In my screenshot below, the whole form is properly displayed in desktop as you have mentioned.

     

    I mobile view, from my end, almost full form is being displayed except the submit button is not showing.

     

    Can you please try re-embedding your form without the <script> portion of the code? Manually set the height of the iFrame as well as shown below.

     

     <iframe id="JotFormIFrame-60530656199865" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotform.co/60530656199865" frameborder="0" style="width:100%; height:1000px; border:none;" scrolling="no"> </iframe>

     

    Let us know how it goes.

    Regards.

  • Profile Image
    Rainbowcolours
    Answered on January 26, 2017 at 06:21 PM

    Hi Christian

    Thank you for your help.

    I did what you suggested and it works well for the desktop, but on mobile it was still not the full form.

    So I pulled down the form to make it longer and now the whole form is there.

    I just put through an enquiry and uploaded an image and it worked.

    Is the new version of JotForm going to be any better?

    Kind regards

    John

  • Profile Image
    Chriistian
    Answered on January 26, 2017 at 08:45 PM

    I am glad to know that the form works properly now. Yes, the Jotform v4 has improved features that will make building forms easier for the users. You will be able to easily edit the form and preview them directly on the same page. Designing forms for mobile and desktop is easier, and you can even design your forms while on your mobile device and preview it instantly.

    If you need further assistance, please let us know.
    Regards.