Email replies contain only part of the input data

  • Profile Image
    CTec
    Asked on January 26, 2017 at 04:01 AM

    Hi

    On a form, I've have on our company website, the data coming through in the response email, from submissions, is suddenly only sending through the first 2 fields. I've checked and the data is on the server but is not being sent.

    Thanks in advance.

  • Profile Image
    BJoanna
    Answered on January 26, 2017 at 05:01 AM

    I have cloned your form and made tests on my cloned form and I was able to replicate mentioned issue. 

    This is happening because your fields does not have labels and you have added custom names to questions inside of email Notification table.

    You can disable Hide Empty fields option inside of your existing email Notification to resolve this issue.

     

    Or you can create new email Notification and leave it with blank question for fields that do not have labels. 

    Hope this will help. Let us know if you need further assistance. 

  • Profile Image
    CTec
    Answered on January 26, 2017 at 05:37 AM

    Thanks BJoanna

    It has worked by switching off the "Hide empty fields" option. The strange thing is that I never switched that option on in the first place, it just started happening.

  • Profile Image
    BJoanna
    Answered on January 26, 2017 at 05:42 AM

    Your're welcome.

    Hide Empty Field option is turned ON by default inside of email Notification and Autoresponder settings. 

    Feel free to contact us if you have any other questions or issues.

  • Profile Image
    CTec
    Answered on January 26, 2017 at 06:21 AM

    Hi BJoanna

    I don't mean to sound pedantic (now that it seems to be working) but the emails yesterday were suppressing data from fields that had been filled out - i.e. they were not blank. I've attached an image of the data stored on your server with an inset of the contents of the related email I received.

     

  • Profile Image
    Ian
    Answered on January 26, 2017 at 07:04 AM

    The issue does not appear to be there any longer now. I checked the Notification settings and Hide Empty fields is set up to No.So even if the fields are left blank, they will still appear in the Email

    I tested the form and the data filled appears correctly in email.

    Just to stay on the same page I cloned the form https://form.jotform.com/61862491763969 

    Here are the results of my tests

    Please try again and let us know if you still face any issue.

     

  • Profile Image
    CTec
    Answered on January 26, 2017 at 07:14 AM

    Hi Ian

    The issue does appear to be resolved. However, I was merely pointing out that the return emails were suppressing email data of filled out fields prior to switching the "Hide Empty Fields" to off.

    Thanks for your assistance.

  • Profile Image
    liyam
    Answered on January 26, 2017 at 07:31 AM

    Thanks for the clarification, CTec.

    Feel free to let us know if you have other questions or concerns.

    Warm regards.