What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    IE 11 : Users are not able to submit form. It just says "Please wait..".

    Asked by BAAudit on January 27, 2017 at 12:12 PM

    it reads, "please wait" and does not submit

    tried various other browsers with same results...

  • Profile Image
    JotForm Support

    Answered by ashwin_d on January 27, 2017 at 12:51 PM

    Hello BAAudit,

    With which form you are having this issue with? I did test your last edited form "DM Control Form" and did not find any issue with that. I was able to submit your form successfully. Please check the screenshot below:

     

    Have you embedded your form in any webpage where you are having this issue with? Please share the webpage URL and we will take a look.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by BAAudit on March 03, 2017 at 05:42 PM

    hi,

    all forms are being sent out via link on emails...

     

    there are still number of people having the same issue especially when they are using IE...

    for Chrome, it seems it has better success...though when they do encounter this issue, i have them clear out their Cache...which seems to work thereafter...

     

    what else can be done so that all users regardless of their browser it will work smoothly...?

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 04, 2017 at 04:48 AM

    Hello BAAudit,

    This is strange. I also tested your form in IE as well but I am still unable to replicate the issue you are having. I was able to submit form successfully. Please check the screenshot below:

     

    I am not sure what is causing this issue. I would suggest you to please add "NoScript" widget in your form and see if that solves your problem. 

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by BAAudit on March 13, 2017 at 01:18 PM

    i'm not sure what to do here with IE users..

    i'm testing my forms (first form)

    https://form.jotform.com/70577220543150

    that links to the below (2nd form)

    https://form.jotform.com/BAAudit/DM-Form

     

    when i use Chrome, it works fine...when i use IE 11, when i click on the "Next" button from the first form, the "next" button changes to "please wait" and it gets stuck there...as i'm writing this, it's been 2+ minutes and it is still waiting...i don't think it is the internet speed as it works fine with Chrome...

    let me know what else i can do...

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 13, 2017 at 02:35 PM

    Hello BAAudit,

    This sis strange. I did test your form again in IE and when I click on the "next" button which is actually a submit button, form was submitted successfully and the thank you message was displayed with URL of second form. 

    I am not sure what is causing this. I would suggest you to please test your form in any other system with IE browser and see if the issue persists.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by BAAudit on March 14, 2017 at 02:57 PM

    i had few people across the country test the form out...

    they are all telling me that Chrome browser works but IE does not...

    same message, "please wait" and does nothing...

    one from east coast, southern california, northern california...

    all telling me the same thing...

    i just tried going to www.jotform.com using IE and logged in as myself...

    myForms show up but i cannot do anything in it...no editing of forms, preview, etc.

    perhaps, its some sort of setting in IE that is blocking jotform...

     

     

  • Profile Image
    JotForm Support

    Answered by John_Benson on March 14, 2017 at 04:28 PM

    Hi,

    I could not replicate the issue. I did a (2) test submissions to your form using Internet Explorer 11 and it is working fine. Here's the version of my IE 11:

    Here's a screen animation clip of my test submission:

    Note: I tested it on Mozilla Firefox, Internet Explorer 11, Microsoft Edge and Google Chrome, it is working fine.

    Is this form embedded on a webpage? If yes, please try to re-embed using the iFrame method. This will prevent script conflicts between the form and the webpage. Here's a guide: https://www.jotform.com/help/148-Getting-the-form-iFrame-code. Please provide the URL of the webpage as well.

    I will clear your form cache to be refreshed in our server. Please try it again and if the issue persists, please provide the IE 11 version so we can investigate it further. 

    You may also suggest to your user to clear his/her browser cache.

    Hope that helps. Thank you.

  • Profile Image

    Answered by BAAudit on March 14, 2017 at 05:21 PM

    hi 

    i replied to the email that i received with screen shots of my IE and what i see when i use IE11...

    i've only given the link to the form via email so they are not embedded on a webpage...

    and i've tried clearing the cache but still the same result...

    thank you

  • Profile Image
    JotForm Support

    Answered by Mike_G on March 14, 2017 at 06:49 PM

    I have submitted your form thrice and like my colleagues, I wasn't able to reproduce the issue you are having in Internet Explorer 11.

    Also, I would like to apologize, the screenshot(s) you tried to include in your last reply did not post as expected, can you try to post it again directly on this thread (not via email) following the instructions in this guide: How-to-include-screenshot-image-in-the-support-forum

    We will wait for your response.

    Thank you.

  • Profile Image

    Answered by BAAudit on March 16, 2017 at 05:32 PM

    as you can see from the IE screen shot, i'm not able to select the form, thus the menu above, "folders, Delete, Submissions, etc." does not appear when using IE..thus i can't use IE at all...

    i'm assuming there is some connection when it comes to the forever "please wait" cycle...

    thank you

  • Profile Image
    JotForm Support

    Answered by Ian on March 16, 2017 at 09:09 PM

    I am forwarding the issue to our development team so they can look into it and update you.