Users are unable to input in form.

  • Profile Image
    CCSS_conference
    Asked on January 30, 2017 at 10:53 AM

    Some form users are reporting they are unable to select items or enter text on this form despite trying different browsers, clearing cache, etc.  I'm having no issues using Safari, so I'm struggling to troubleshoot.  I know there was an issue on Friday with the "print/review" widget so I removed that, but users are still having issues.  

    ("Create PDF" is also hanging and never completing on this form for some reason.)  Thank you!
  • Profile Image
    ashwin_d
    Answered on January 30, 2017 at 11:59 AM

    Hello,

    I'm sorry for the trouble caused to you. 

    I did test you form in Firefox, Chrome & IE browser and I am unable to replicate the issue. I was able to submit your form successfully without any problem.

    Have you embedded your form in any webpage where you are having this issue with? Please share the webpage URL and we will take a look.

    We will wait for your response.

    I have moved your question related to PDF to a new thread and you will be answered here:  https://www.jotform.com/answers/1050490

    Thank you!

  • Profile Image
    CCSS_conference
    Answered on January 30, 2017 at 03:08 PM

    Thank you for the quick response.  I asked some users to describe the problem and it has something to do with the collapsed sections.  Some users report they are unable to open the sections to complete the form.  They were not hidden, just closed by default.  So I changed all of them to "open", but users still reported some of the widgets (dynamic dropdowns and configurable list) were either not populating at all or not allowing them to input text.  In reading some of the widget forums, some others have had issues with conflicts between page breaks/collapse and widgets.  I just removed the page collapse entirely and hope it fixes the problem.  Again, this was across browsers but only a handful of users, though they all reported the exact same form behavior.

  • Profile Image
    Boris
    Answered on January 30, 2017 at 04:01 PM

    Is your form embedded on a website? If so, please send us a link to the page where the form is embedded, so that we can take a look whether there are any scripting conflicts that would be causing such issues for your users.

    When I look at your form over the form's direct link that you have shared, it appears to be working fine:

    https://www.jotform.com/CCSS_conference/invited

    This form doesn't have any Form Collapse fields.

    Just to check for possible issues, I have cloned your form into my account for testing, added Form Collapse fields to the cloned form, and they worked fine as well. Here is a screen recording from one of the tests:

    Should you keep experiencing the issues, please do send us a link to the page where the your users are experiencing the issue, and we'll gladly take a closer look whether there are any issues there that would be causing it. Thank you.

  • Profile Image
    CCSS_conference
    Answered on February 01, 2017 at 12:14 PM

    No, the form is not embedded.  Users are given a direct link to JotForm to complete the form.  I removed the form collapse hoping it would fix the conflict.  The form works perfectly on my computer.  I haven't been able to duplicate the issue.  I'm hearing from users (who are very computer literate) that some of the form components will not work on their computer.

    Some report (who are very computer literate) that parts of the form will not work on their computer, but will work on a co-workers.  I've struggled to find the answer to this except to remove the collapse and I may need to remove some of the widgets if it continues to be an issue.

    For your reference, some have reported (when the form had them) that they would click on the form collapse sections and nothing would happen, they would not open.  Once I set them all to open by default, users still reported issues with the widgets, like not being able to type in the text box of "configurable list" and not seeing the dropdown for "dynamic dropdowns" at all, just open white space.

  • Profile Image
    BJoanna
    Answered on February 01, 2017 at 02:40 PM

    I have also tested your form and I am not able to replicate mentioned issue. I also noticed that you have removed Form Collapse fields and Configurable list widget from your form. I have added them to my cloned form, but I am still not able to replicate issue that your users reported. 

    Is the form now working for all of your users? Also did you previously asked your users to try with some other browser? 

    You can try to clone your form and add them back and provide your users cloned form, so that they can test it.

  • Profile Image
    CCSS_conference
    Answered on February 01, 2017 at 05:58 PM

    I would rather not take a chance adding those items back (collapse fields and dynamic dropdown), since the form completion deadline is this week.  Users have reported that it didn't matter which browser they used, if they were unable to see the field in chrome, they were unable to in firefox.  The configurable list widget was different in that they could see it, but were unable to click into it to enter text.

    Again, I have not been able to replicate the issue myself, but I would estimate 1 in 3 users has needed to email me their submission today because it was not working.  Some completed the entire form, but because they didn't click the dynamic dropdown question that was required, it would not submit the form and reverted to a blank version.

    It has been incredibly frustrating to try to work through issues today that don't seem to have a rhyme or reason.  I've used JotForm for our last 3 conferences and never had issues.  It seems these developer widgets aren't always compatible.  

  • Profile Image
    Kevin_G
    Answered on February 01, 2017 at 09:08 PM

    Apologies for the inconveniences this may have caused to you. 

    Unfortunately, I cannot replicate the same issue you're mentioning, like my colleagues, I have cloned your form and performed some tests, I could not get to replicate the issue even adding widgets or collapse tools. 

    May you provide us with the device details where your users replicated the issue? 

    We will be glad to test in similar or, if possible, the same OS version or web browser version in order to find if we're able to replicate the problem. 

    Also, if possible, check the web console while working on the form, if there is a conflict then we should be able to see it displayed in the console. 

    These keyboard shortcuts will help you to get it: 

    Google Chrome:

    Mac: Command + Option + J

    Windows: Control + Shift + J

     

    Firefox:

    Windows: Ctrl+Shift+K

    Mac: Command+Option+K

    This guide will help you to add the screenshot with your next reply: How-to-add-screenshots-images-to-questions-in-support-forum