What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Builder 4.0: Stripe integration defaults to Test Mode even when it is configured to Live Mode

    Asked by Redlemon on February 01, 2017 at 10:49 AM

    Strip integration won't stay in Live mode

    I can connect to my stripe just fine and set it to live mode, and the verification goes through fine. But if I close the form and enter it again the live mode has gone back into test mode. Any idea why this might be happening?

    Page URL:
    http://linchpin.uk.com/free-trial.html

  • Profile Image
    JotForm Support

    Answered by Boris on February 01, 2017 at 11:22 AM

    Upon checking out your form 70262641735353, I see that it is successfully integrated in Live Mode:

    I have also opened your form in our Form Builder, and upon accessing the payment wizard, I see that it remains correctly in Live Mode. Here is a screen recording of the test:

    However, I believe I managed to reproduce the issue you are describing with our new Form Builder version 4. When the form is loaded in V4, it will default to showing you "Test Mode" in the configuration wizard.

    If you connect it again in Live Mode, it will correctly show Live Mode for the remainder of your session, and only revert back to showing Test Mode the next time you reload the Form Builder:

    I have escalated this as a bug to our developers, and we will update you as soon as the issue is resolved. Until then, I would recommend that if you are making changes to the Stripe payment field, please at the end of making changes simply make sure that it is set to Live Mode and that it is connected.

    Thank you.

  • Profile Image

    Answered by Redlemon on February 01, 2017 at 11:30 AM

    Great, thank you!

  • Profile Image
    JotForm Developer

    Answered by omur on February 01, 2017 at 01:30 PM

    Hello Redlemon,

    I've pushed an update that fixes the issue.

    You're form is correctly being displayed in live mode now. It was always in live mode but being able to see that it is actually displayed in live mode should also be a good thing I suppose!

    Thank you very much