One of the form fields is not shown on form

  • Profile Image
    ipbr21054
    Asked on February 01, 2017 at 07:22 PM

    Hi,

    I used to receive in my form a link for the field "Link To Part Number"

    Where this link should be now I just get a blank field  

    The form in question is 62115565434352

    For an example in my submissions for this for there was an email with it showing on January 20th I think

    I'm doing this from memory as on iPhone in bed ha ha 00:25

     

    Thanks.  

     

  • Profile Image
    Kiran
    Answered on February 01, 2017 at 09:50 PM

    I have cloned your JotForm and see that the field Link to Part number field is set to be hidden on the form.

    Click on Advanced tab in the field properties and change the option 'Hide field' to OFF so that the field should be displaying normally on the form.

    Hope this information helps! 

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 06:03 AM

    The reason it is hidden in the form is i dont need the customer to see it.

    When i receive the email i can then see a link to the item in question.

    As you can see the Red arrow shows the part number.

    Where the green arrow is pointing the area is empty.

    The empty are SHOULD show the link like this,

    http://www.theremotedoctor.co.uk/m-images/emailref/Honda047.html

  • Profile Image
    owen
    Answered on February 02, 2017 at 06:16 AM

    Hi,

    Your current email configuration is somehow disrupted. What I suggest you is to delete the existing one:

    And, re-create a new one. This should resolve your issue. Do let us know if it persists though. 

    Please contact us again if you need any further assistance. 

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 06:36 AM

    Strange but i would like to use this email as its what i use for my business.

    Using a different email isnt quite right ?

     

    Any advice

  • Profile Image
    owen
    Answered on February 02, 2017 at 06:38 AM

    I'm sorry, I didn't mean you should use a different email address. I just suggested you to delete your current configuration and re-create a new configuration with the very same email address. The issue is not related with your email, it's just your configuration on our end. 

    Please remove it and re-add it, it should work. It's like a reset. 

    I hope this helps. Sorry for the confusion.

    Kind Regards

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 06:48 AM

    Hi,

    Ive done as advised then completed another form.

    But still it is missing.

    See image supplied.

  • Profile Image
    owen
    Answered on February 02, 2017 at 07:00 AM

    Thank you for your quick actions. Now, I have one question in mind. How do you fetch data to that particular field? It has no conditions, it is hidden so, there is no way to fill it out. Did you have conditions for that which are no longer there? Currently, I can't see a way how that field is filled. 

    Please let me know how you used to do it. I can provide further assistance then. 

    Thank you!

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 07:02 AM

    OK,

    Please let me check at my end.

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 12:47 PM

    Hi,

    I have checked all my back up files and all are character for character so no problem there.

    Below i have supplied a screen shot from an email i received through your site.

    The date was January 20th.

    As you can quite clearly see THEN the field that is now missing was actualy being inserted.

    This is the link that is shown below,

    http://www.theremotedoctor.co.uk/m-images/emailref/Honda044.html

     

    Any advice please because all of a sudden its stopped working ?

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 01:24 PM

    Hi,

    Ive gone through my trash bin an found an old form which has the working url on it.

    This is the form number 62132101009335

    Check out the screen shot from the completed form i just sent myself.

  • Profile Image
    jonathan
    Answered on February 02, 2017 at 02:46 PM

    I reviewed your form https://www.jotformeu.com/form/62132101009335 and I found that there was and existing condition rule that populate the hidden field upon submission.

    This was the reason in the email notice, the hidden field have data on it.

    --

    While your new form https://www.jotformeu.com/form/62115565434352 does NOT have such similar condition logic on it. So there is no means for the hidden field to have value or be populated in the email notice.

    Here are the conditions on this form:

     

    You can see now the difference between your 2 forms. Just add the same condition logic on the new form if you wanted the field populated also similar to how the other form have work before.

    Let us know if you need further assistance.

     

     

     

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 02:58 PM

    I now know what to do but i dont see the IF option for the condition im using v3

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 03:22 PM

    Sorry i mean i dont see INSERT option

  • Profile Image
    jonathan
    Answered on February 02, 2017 at 03:26 PM

    You need to use the Calculate/Update option of the Condition Logic tool.

    User guide: https://www.jotform.com/help/268-Conditional-Logic-Inserts-Text-Calculation-Into-A-Field

     

    Here is a video guide you can review.

     

    Let us know if you need further assistance.

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 03:31 PM

    This is so painful it really is.

    Are you telling me that i now have to enter the url for every item /

     

     i Have plenty of url

  • Profile Image
    jonathan
    Answered on February 02, 2017 at 03:48 PM

    Are you telling me that i now have to enter the url for every item /

    I am not sure what you meant.  The text URL is was suppose to be the value you wanted to be in the hidden field Link to part number.

    This text URL "http://www.theremotedoctor.co.uk/m-images/emailref/Bmw004.html"

    All that is needed is to create 1 condition rule to do it.

    --

    Here is my test https://form.jotform.com/70325675943967 form version. The email notice shows the hidden field with value... 

     

    You can try submitting my test form. Use your own email so that you can receive the auto email and you can see how the email will be.

    Let us know if still not resolve.

     

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 04:10 PM

    I am now looking at my old for which works no problem.
    I am going backwards to do this.

     

    The part number should pull the link from my code on the page.

     

    I have over 100 part numbers so your form should pull the correct url for me to see in my form NOT me to add 100 url.

     

  • Profile Image
    jonathan
    Answered on February 02, 2017 at 04:17 PM

    Thank you for the explanation and clarification. I see now how you did on your old form with regards to assigning the Part Number value .

    It is actually similar... you just need to manually put in the text URL and insert in between the Part Number field 

     

    So you do not have to create hundreds of conditions for each part number.

    I hope this is clearer now. Let us know if you can't still do it.

    Thanks.

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 04:19 PM

    Please just do it for me

  • Profile Image
    jonathan
    Answered on February 02, 2017 at 04:35 PM

    I have now applied the needed condition on your form https://www.jotformeu.com/form/62115565434352

     

    You can test the form to see how it goes. Let us know if still not resolved.

    Thanks.

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 08:03 PM

    Thats great news.

    Checking it now with a couple completed forms i can advise IT NOW WORKS LIKE IT DID.

    Are you able to add some credits to my account for the completed test  forms that ive had to send myself.

     

    Many Thanks.

  • Profile Image
    ipbr21054
    Answered on February 02, 2017 at 08:18 PM

    Ive now added the following code to the form,

    div#cid_30, select#input_30 {

        text-align-last : center;

        width : 170px !important;

    }

     

    Please take a look at the for now,

    http://form.jotformeu.com/form/62115565434352?partNumber=Mercedes003

     

    Why does the background go transparent,i removed the code but the background stayed transparent ?

    Please advise how i get the correct looking for back.

     

    Also so i dont mess the form up again i am trying to get the 2 fields the same size & correct alignment.

    As you can see by the photos below the top field is to the left or the one below,i would like them the same please.

  • Profile Image
    jonathan
    Answered on February 02, 2017 at 09:27 PM

    Are you able to add some credits to my account for the completed test  forms that ive had to send myself.

    You can delete all those test submissions in the View Submission panel of your form. After you have deleted the submissions, it will restore your submissions counter.

    Please take caution and delete only those test submissions and not your actual data.

    Deleted submissions are permanently gone so we will not be able to recover them once deleted.

    Let us now if you need further assistance on this.

    --

    The next question was about a different issue. We will resolve it on its own thread here 

    https://www.jotform.com/answers/1055473

     

  • Profile Image
    ipbr21054
    Answered on February 03, 2017 at 07:38 AM

    I was refering to the forms that i have had to send myself to see what the form received would look like.

    I have had to use my own credits to do this,all this has been taken out of my allowed credit email.

  • Profile Image
    seth
    Answered on February 03, 2017 at 08:13 AM

    Hello,

    We don't have authorization to increase your limits. However, if you get in trouble at the end of the month, please contact to us again and refer to this thread. We will help you out to increase your limits temporarily at that time. Hence, no worries, we can help you out if you encounter limit problems.

    You can increase your limits for free by engaging here: https://www.jotform.com/myaccount/getMore

    Please feel free to contact us for your further queries.

    Regards.