What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Authorize.net: PCI Error on Transaction

    Asked by tntnutritioncoach on February 04, 2017 at 08:55 AM

    Hello, I've been using jotform for years, all of a sudden 1 (only 1) of my many forms I use to take credit cards while not present is giving me a PCI error. I've researched the forum, I re-entered my AIP credentials and even created a new transaction key just in case. I double checked my authorize.net account and my settings are correct. Things are working find on my other forms, just all of a sudden 1 day this one stopped working right around when you launched then new jotform 4.0. I haven't tested the new form yet I was hoping someone on your side could look at this for me to see if there is anything else I should do? I've uploaded a screen shot of error message. 

    Page URL:
    http://www.tntnutrition.org/re-enrollment-options/

    Screenshot
  • Profile Image
    JotForm Support

    Answered by EltonCris on February 04, 2017 at 10:38 AM

    Thanks for reporting and apologies for the inconveniences caused. I have now escalated this to our developers for further investigation.

    You will be informed here once this is fixed.

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 04, 2017 at 10:47 AM

    By the way, I think this issue might have something to do with Form Encryption that is enabled in your form. We suggest to try disabling it for now while this problem is being investigated by our dev team. This might help.

  • Profile Image

    Answered by tntnutritioncoach on February 08, 2017 at 06:52 PM

    Hello, 

    I have followed all of your instructions and it is still not working. Getting another PCI error message for the same form on this page http://www.tntnutrition.org/re-enrollment-options/  should I clone it or something? I'm now worried all my forms are having these issues, is there a way for you to test the the following:

    https://form.jotform.com/62013899552158

    https://form.jotform.com/60756812735158

    https://form.jotform.com/53375026272150

     

  • Profile Image
    JotForm Support

    Answered by Chriistian on February 08, 2017 at 10:19 PM

    I cloned your form and sent a submission on sandbox mode. I also encountered the issue that you reported. You can also test on your end with the help of this guide: How to Test Authorize.net Payment Tool on Sandbox Mode?

    However, once I deleted the Authorize.net integration and re-added it again, I was now able to submit the form successfully. The sandbox payment was listed in the submissions without any issue.

    Since deleting a field might affect the data on previous submissions, may I suggest that you clone the form where you encountered the issue. Then on the cloned form, delete the Authorize.net integration and add it again.

    If the issue persists, please let us know.
    Regards.

  • Profile Image

    Answered by tntnutritioncoach on February 15, 2017 at 04:49 PM

    All of my forms are STILL NOT WORKING....I have cloned every single one. I have updated the transaction key for authorize.net and still getting issues. I have deleted and re-added my authorize.net info. I switched back to jotform 3.0! I CANNOT ACCEPT ANY PAYMENTS RIGHT NOW, PLEASE HELP

    I AM GETTING THE EXACT SAME PCI ERROR MESSAGE AS PREVIOUSLY SUBMITTED

     

     

    https://form.jotform.com/70393541885161

    https://www.jotform.com/tntnutritioncoach/999--16-week-coaching-program-new

    https://form.jotform.com/70394102353145

    https://form.jotform.com/70447392075156

    https://form.jotform.com/70453409003143

     

  • Profile Image
    JotForm Support

    Answered by Chriistian on February 15, 2017 at 06:04 PM

    Hi @tntnutritioncoach,

    Thank you for trying my suggestion. We are sorry for the inconvenience this has caused you. I am following up the issue with our developers since this has been escalated to them. We will update you as soon as this is fixed.

    Regards.

  • Profile Image

    Answered by tntnutritioncoach on February 15, 2017 at 06:40 PM

    What timeline are we looking at? I may need to create an alternative solution right now until this gets corrected.

  • Profile Image
    JotForm Support

    Answered by Chriistian on February 15, 2017 at 08:27 PM

    Unfortunately we cannot provide you with a specific timeline on when this issue will be fixed, as our developers are working on several tickets. Rest assured this issue is marked as Important and our backend team are working towards resolving this as soon as possible.

    Regards.

  • Profile Image

    Answered by tntnutritioncoach on February 17, 2017 at 01:24 PM

    Any updates on status of all my forms? 

  • Profile Image
    JotForm Support

    Answered by Kevin_G on February 17, 2017 at 02:37 PM

    @tntnutritioncoach, 

    Unfortunately we have not received any update regarding this issue, I will ask for updates to the assigned developer and will let you know as soon as we get any notice about it. 

    Thank you. 

     

  • Profile Image
    JotForm Support

    Answered by Kevin_G on February 17, 2017 at 02:41 PM

    OK, I have received an update from the developer assigned to this ticket and he's currently working on it, this will be resolved today and he will let you know via this thread when it's done. 

     

  • Profile Image

    Answered by tntnutritioncoach on February 17, 2017 at 02:44 PM

    Thank you Kevin!

  • Profile Image

    Answered by tntnutritioncoach on February 21, 2017 at 09:08 AM

    I have not heard from anyone, an update would be appreciated, thank you

  • Profile Image
    JotForm Support

    Answered by Kevin_G on February 21, 2017 at 10:50 AM

    Apologies for the inconvenient, I will ask again for any update and will let you know as soon as possible. 

     

  • Profile Image

    Answered by tntnutritioncoach on February 23, 2017 at 11:52 AM

    CAN YOU PLEASE HELP ME?! I have done everything, plus some. I've even tried to create just a new form all together and now I'm getting a different PCI error, which my login credentials are correct. Literally, since you rolled out Jotform 4.0 I have problems with Authorize.net integration. before them I had zero issues. I'm going to have to switch my form companies because you can't resolve this issue! 

  • Profile Image
    JotForm Support

    Answered by Kevin_G on February 23, 2017 at 01:05 PM

    That error happens when you have entered wrong API info, I have checked on my end and the integration seems to be working, integration verifies fine, form is also submitting and sending the payment without any problem. 

    In order to know if the problem is with the v4 builder only, you could try switching to the v3 builder and reintegrate your form to see if that works. 

    To switch back go to your account settings and select the v3 as default builder: https://www.jotform.com/myaccount/settings 

    Please, do let us know how it goes. 

  • Profile Image

    Answered by tntnutritioncoach on February 23, 2017 at 02:18 PM

    My API info is correct. All of a sudden the form below started to work when it wasn't 2 weeks ago:

     

    https://form.jotform.com/70447392075156

     

    I switched to jotform 3.0, put the SAME API info in, tested in Sandbox mode, I even created a new test form, and still same message. I still have two major forms I collect payment that aren't working: 

     

    https://form.jotform.com/70394102353145

    https://www.jotform.com/tntnutritioncoach/999--16-week-coaching-program-new 

     

    NO ONE in the past 2 weeks has been able to resolve this and I am losing money along with time. I think I may have to leave Jotforms.

  • Profile Image
    JotForm Support

    Answered by Jan on February 23, 2017 at 04:05 PM

    We understand how you feel and we are sorry for the inconvenience. This escalation ticket is already assigned to a developer that specializes in payment integration.

    Let me contact the developer and ask for any update. Thank you for your cooperation.

  • Profile Image

    Answered by tntnutritioncoach on February 23, 2017 at 05:33 PM

    Since No one is getting back to me, I:

    I switched back to Jotform 3.0 (I did this temporarily at first)

    I re-entered my Authorize.net info (for 3rd time-my credentials never changed)

    I changed themes (1st time doing so)

    I removed encryption (I tried this before and it didn't work)

     

    For whatever reason the forms are working, for now. I don't know what it was, I tried all of the above in pieces but never worked. Jotform 4.0 I think definitely has bugs.

  • Profile Image
    JotForm Support

    Answered by Kevin_G on February 23, 2017 at 06:44 PM

    Thank you for letting us know that it worked when you disabled the encryption feature, I can see in the ticket opened that encryption seems to be causing the issue, this has been also said above  by one of my colleagues above

    We'll also update you as soon as possible. 

    Thank you for your understanding. 

     

  • Profile Image

    Answered by tntnutritioncoach on February 23, 2017 at 07:18 PM

    Yes, I had disabled the encryption before as your colleague said to but that still did not resolve the problem. I added it back in for testing amongst other variables, removed it again. For whatever reason something worked. 

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 23, 2017 at 08:23 PM

    Great! Glad to hear that it worked for you know.

    I think I forgot to mention that recreating the field after disabling the form encryption might somehow help.

    Anyway, we'll still leave this ticket opened so our developers will look into this and fixed it as soon as they're able to see this.

    Thanks for your cooperation, we appreciate it.

  • Profile Image

    Answered by DrivePayments on March 29, 2017 at 11:32 PM

    Any update on this? We have forms that are starting to do that. nutritioncoach, did you end up switching to a different system?
  • Profile Image
    JotForm Support

    Answered by Chriistian on March 30, 2017 at 01:17 AM

    @DrivePayments,

    To better assist you, I have moved your concern to a separate thread. You can find it here: https://www.jotform.com/answers/1106285. We will attend your concern there shortly.

    Regards.