I published my site with a jotForm, and the form doesn't work.

  • Profile Image
    kksumlin
    Asked on December 22, 2010 at 10:06 PM

    When you click on the fields to enter info, nothing happens...no cursor to enter info.

  • Profile Image
    aytekin
    Answered on December 23, 2010 at 02:47 AM

    Can you post the URL of the page?

    Have you tried the IFrame version of the code instead? On the Form Builder:
    1. Open "Setup & Share" tab on toolbar,
    2. Click on "Share Form"
    3. Click on "Advanced Options"
    4. Click on "IFrame Code".

  • Profile Image
    bunyavista
    Answered on March 11, 2011 at 12:12 AM

    Hi,

    I am having a problem with the form on IE8 on bunyavista.com.au/location.html I have done as you suggested using an iframe instead.

    As you can see there is no cursor that comes in First name.

    Thank you for your advice.

  • Profile Image
    liyam
    Answered on March 11, 2011 at 10:00 PM

    Hello bunyavista,

    I checked the URL that you have provided and it seems that there's no file called location.html. although I saw a location.htm but it does not have a form in it.  The only form that I saw is in contact.htm.

    What I noticed is that it's not loading properly due to some errors, you might have forgotten to remove some parts of the form when it was still not in i-frame.

    I checked the HTML source code of your page and I saw this:

    <script type="text/javascript">
            validate("q_form_10953547507");
    </script>

    As you can see, your form is already in iframe and this javascript function "validate()" will try to look for that code function but is no longer part of your page.

    Another thing that I noticed is this:

    <a target="_blank" href="location.htm">
    <H1>Dalby Motel Accommodation</H1>
    <h3>Contact us by filling the form below:</h3> ...

    A closing anchor tag "</a>" is missing.  In IE8 this is causing most of the middle part of the page (starting from the main header going down) to have the page when clicked go redirect to location.htm.  This includes when trying to click on the textbox fields in your form inside the iframe.  Please add a closing anchor tag and I believe this will fix all your problems.

    Hope this helps