I am unable to submit my form.

  • Profile Image
    Varun1103
    Asked on February 09, 2017 at 12:51 AM

    For some reason, I am unable to submit my form even though all the required fields have been filled up. I have also enabled the setting "Clear required fields on Hiding' in the preferences. 

    This is the error that keeps popping up:

     

     

    Is there any particular reason for this? I've noticed that this error seems to appear whenever respondents change their answers for required fields. 

    Please look into this as this is worrisome since we do not know how many people to date have been unable to submit the form due to this error.

    Thanks,

    Varun 

  • Profile Image
    ashwin_d
    Answered on February 09, 2017 at 01:42 AM

    Hello Varun,

    I did test your form and I am unable to replicate the issue you are having. I was able to submit your form successfully and thank you message was displayed. Please check the screenshot below:

     

    Have you embedded your form in any webpage where you are having this issue? Please share the webpage URL and we will take a look.

    We will wait for your response.

    Thank you!

  • Profile Image
    Varun1103
    Answered on February 09, 2017 at 01:53 AM

    Hi Ashwin,

    Thanks for the response. Yes, the form is embedded on our company site. You can access it through this link: http://www.21dojo.com/assessment-hall.html.

    Hope you can identify what causes the problem,

    Cheers,

    Varun

  • Profile Image
    owen
    Answered on February 09, 2017 at 02:18 AM

    Hi Varun, 

    I was able to submit your form, which is embedded on the website you provided, without an issue. You should've received the notification of it. There are two possible reasons why you might get that error though:

    1. You have unfilled required fields on your form.

    2. There are script conflicts on your webpage where the form is embedded. This one is more likely. In order to resolve this you should embed your form with the iFrame method on your website. 

    I hope this helps. 

    Please contact us again if you need any further assistance. 

  • Profile Image
    Varun1103
    Answered on February 09, 2017 at 08:12 AM

    Hi Owen,

     

    Thanks for replying. We have actually already embedded the form using the iFrame method. Also I was ensuring that all the required fields were filled before submitting the form. I've enabled a setting that does not allow you to go to the next page of the form unless you fill in the required fields in that page.

    Anyway since then, I've retried a couple of test submissions and they went through without any issues. Hopefully this was a one-off problem. 

    Thanks,

    Varun

  • Profile Image
    owen
    Answered on February 09, 2017 at 08:32 AM

    Hi again Varun,

    I am glad to see that it is all sorted now. I hope it was a temporary glitch on your form indeed. 

    Thank you for contacting us!