Image link added in form always shows undefined form URL.

  • Profile Image
    dmichaels
    Asked on February 10, 2017 at 11:45 AM

    On my Mishloach Manot 2017 Order form, our logo appears at the top and the link should take the user back to our home page

    www.tbsmahopac.org.

    When I hover over the image in the form builder, it shows the correct address as above, but when previewing or running live, it changes to https://www.jotform.com/form/undefined

    I tried deleting the image and re-adding, but had the same result.

    IN fact, as I'm writing this I'm checking my other logos on other forms, and they all end in /undefined. They don't go to my home page.

    In technical terms, something bad has happened.

  • Profile Image
    ashwin_d
    Answered on February 10, 2017 at 01:17 PM

    Hello dmichaels,

    I'm sorry for the trouble caused to you. 

    I did test your form and I am able to replicate the issue you are having. It seems if you add link in image field of form, the link does not work correctly and always displays following URL:  https://form.jotform.com/undefined

    I am reporting it to our backend team. We will get back to you as soon as we have any update from them. For now, I would suggest you to please add a "Text" field in form to add an image and hyperlink. Please check the screenshot below:

     

    Thank you!

  • Profile Image
    EltonCris
    Answered on February 11, 2017 at 02:52 AM

    This is now fixed. Please check it again. Thanks

  • Profile Image
    dmichaels
    Answered on February 11, 2017 at 08:45 AM
    Thank you
    ...