How can I remove "Please fill up the credit card details" notification

  • Profile Image
    cng
    Asked on February 13, 2017 at 06:49 AM

    FORM LINK: https://form.jotform.com/60386142782963

    I'm trying to make the payment section optional; So I made the section UNREQUIRED when "I wish to make a donation" checkbox field is EMPTY. 

    But the notification "Please fill up the credit card details" still shows up and doesn't allow for form submission. 

     

  • Profile Image
    ashwin_d
    Answered on February 13, 2017 at 09:18 AM

    Hello cng,

    I did check your form and found that it has few conflicting conditions which is causing this issue. I am working on your form's condition but it will take time. I will get back to you as soon as I am able to complete it.

    Thank you!

  • Profile Image
    cng
    Answered on February 13, 2017 at 11:41 AM

    I made a copy of the form and made the payment area unrequired altogether, but the "Please fill up the credit card details" notification still shows up. Why is this? 

  • Profile Image
    cng
    Answered on February 13, 2017 at 12:32 PM

    UPDATE: 

    I kept working at it and realized it works (notification "Please fill up the credit card details" still pops up), but if you press the submit button more times, it goes through with submission. Why is this?

  • Profile Image
    ashwin_d
    Answered on February 13, 2017 at 12:33 PM

    Hello cng,

    I did check your account but did not find any cloned form. You seems to have only one form in your account.

    Can you please let us know the form ID / form URL of your cloned form? 

    We will wait for your response.

    Thank you!

  • Profile Image
    cng
    Answered on February 13, 2017 at 12:40 PM

    https://form.jotform.com/70434477714156

  • Profile Image
    ashwin_d
    Answered on February 13, 2017 at 01:47 PM

    Hello cng,

    The reason why credit card required validation error message was always displaying is because you have set your payment question to populate data from "Calculation" widget. Since by default "Amount" field always have a value by default selected, it populates the data in the payment question.

    I have fixed this issue by removing the default "$10" selection form the "Amount" dropdown. Your form now works as expected. Please check the screenshot below:

     

    I would suggest you to please test your form again and see if it works as expected:  http://www.jotformpro.com/form/60386142782963

    We will wait for your response.

    Thank you!