Stripe: Required error message flashes when no products are selected, and form doesn't submit

  • Profile Image
    PHAppleFest
    Asked on February 16, 2017 at 02:25 AM
    but now the one issue I'm still having could be a problem for users (and then for me), is that if I miss a the required field radio button in the payment field, the error message doesn't stay up, it only flashes for a half a second and a user would never notice it and just think the form isn't working. 
  • Profile Image
    Charlie
    Answered on February 16, 2017 at 03:21 AM

    Hi,

    I tested your form titled "Clone of 2017 Craft Vendor Application": https://form.jotform.us/70458440383154. But I'm unable to replicate the problem. Here's a screencast of my test form:

     

    Was your form perhaps embedded on a website? Or am I testing a different form? I see you have identical forms. 

    We'll wait for your response. 

  • Profile Image
    PHAppleFest
    Answered on February 16, 2017 at 12:22 PM

    Sorry I should have been more specific, it was the dollar amounts (type of space) buttons in the payment options, not the text fields.

  • Profile Image
    PHAppleFest
    Answered on February 16, 2017 at 12:47 PM

    Here is a video of what it looks like, everything else is filled in, it only happens if they leave those buttons unchecked. Which is a high probability, because I had to list those same options again above the payment field so I can have the "inventory" of spaces recorded and deplete as they are taken... I didn't see a way to account for inventory within the payment option?http://perryhallapplefestival.com/wp-content/uploads/2017/02/Screen-shot-2.mov

  • Profile Image
    John_Benson
    Answered on February 16, 2017 at 03:33 PM

    The form "Clone of 2017 Craft Vendor Application": https://form.jotform.us/70458440383154 has been deleted.

    Also, I was not able to see the video link (http://perryhallapplefestival.com/wp-content/uploads/2017/02/Screen-shot-2.mov) you shared. It is not working for me. 

    I checked your "2017 Craft Vendor Application" form. I was not able to replicate the issue. I was able to submit the form without filling up the payment field.

    Please make sure that the product in the payment wizard is not set to "Required".

    Hope that helps. Let us know if you're still having issues. Thank you.

  • Profile Image
    PHAppleFest
    Answered on February 16, 2017 at 03:43 PM

    I deleted the clone, which was made only to try to fix another issue with a mail chimp integration, so the working form is https://form.jotform.com/70094765059160 and the options for the individual items were never set to required. The reason you were able to submit without payment field is that I changed the field to not being required (but it must be in the working form) so I could test it without it going against the allotted 10 payments per month.
    I'm sorry you couldn't see the movie, what happens is if one of those buttons is not selected, the error message flashes under the submit button for just half of a second, but there is no other visible indication that there is something missing, so the user will have no idea why the form is not submitting unless they happen to notice that, which is unlikely, so I'm reluctant to make it live yet.

  • Profile Image
    Boris
    Answered on February 16, 2017 at 06:04 PM

    Thank you for the added details, I was able to replicate the issue you mentioned.

    The issue is with the Stripe payment field. When the field itself is required, and none of the products are selected, an error message flashes briefly:

    Thank you for bringing this to our attention, I have escalated it as a bug report to our developers. We will update you through this support thread once it gets resolved. Thank you.

  • Profile Image
    PHAppleFest
    Answered on February 16, 2017 at 08:17 PM

    Wonderful, thanks so much for your help!

  • Profile Image
    NeilVicente
    Answered on February 17, 2017 at 09:56 AM

    Hi there,

    This is now fixed.

    Cheers!