Authorize.net: Some additional gateway settings are not saving changes.

  • Profile Image
    SunbridgeInstitute
    Asked on February 16, 2017 at 11:07 AM

    I have been setting up my additional gateway settings in the payment wizard, so that the shipping information gets transmitted to Authorize.net, and then through them to our Finance Director. However, my Finance Director keeps complaining that the shipping information is not coming through, and I keep resetting the information. Now I've gone in again and I see that all my settings are reset again. This is at least the third time I've had to add the information. Please see the attached screen shot. Normally I am identifying a field for the invoice number, the shippee name, and the shipping address. Can you please help me work this out so that these fields will stick in my form, and transmit the correct information to Authorize.net?

    Thank you!

  • Profile Image
    Kevin_G
    Answered on February 16, 2017 at 01:54 PM

    I have checked a cloned form of yours and I was able to replicate the issue you're mentioning, seems like some of the additional gateway settings are not saving, not simply resetting to default. I found this when testing in both, the v3 and v4 builders. 

    I will report this issue to our developers so they can investigate and resolve the issue. 

    We will let you know as soon as we get any update regarding this. 

     

  • Profile Image
    Scott
    Answered on February 17, 2017 at 06:43 AM

    Hey Sunbridgeinstitute,

    This issue is now fixed. Please let us know if you have any further issues and we will be happy to help,

    Cheers!

  • Profile Image
    SunbridgeInstitute
    Answered on February 22, 2017 at 10:52 AM

    Hi there. This situation has improved, but we are still having an issue. The home address has been saving, but the invoice number field is still not saving. Also, even though the home address field has saved in the Gateway section, it has not transferred over to Authorize.net. You can see in my screen shot below that the shippee name and shipping address are both still blank. I hope that there is a resolution for this issue, as it is causing a big problem for our finance department, who is trying to tie payments together with the related courses and participants.

    Thank you for looking into it!

     

  • Profile Image
    Nik_C
    Answered on February 22, 2017 at 01:39 PM

    Hello,

    I'm sorry that the issue re-appeared.

    I checked your Authorize.net integration, and I saw that the invoice field is set to none, could you please confirm if that reverted automatically, but it was set before?

    Regarding the customer shipping information, you're referring to First name & Last Name? 

    We'll wait for your response.

    Thank you.

  • Profile Image
    SunbridgeInstitute
    Answered on February 22, 2017 at 01:46 PM

    Yes, I had reset the "invoice number field" to be "summary of selections-short". It keeps reverting to None.

    And as far as customer shipping information, we are aiming to have the first name, last name, and also shipping address come through on our authorize reports. I had a different thread that showed me how to get the name to come through, since this is apparently not a feature of the version I am using (which involved temporarily reverting to the older version).

    It seems like the gateway is holding on to the shipping address field that I assigned, but it is not sending it through to authorize so that it comes through on authorize's report.

    Thank ou for your help.

  • Profile Image
    Kevin_G
    Answered on February 22, 2017 at 03:46 PM

    I have checked checked the integration and noticed what you're reporting, but this will be handled in separated threads since both issues are different and they are not related to this current thread. 

    We will be assisting you about the invoice number field not being saved on this link: https://www.jotform.com/answers/1073463 

    And you will get assistance about the shipping address not passing to Authorize.net here: https://www.jotform.com/answers/1073464