What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    JotForm V4: not showing the edits done on preview.

    Asked by IanRm on February 16, 2017 at 12:08 PM

    Hello,

     

    I've just made ammendments to my form https://eu.jotform.com/build/70404452046952 however they are not coming through on the actual form page or in preview.

     

    The fields in question are not hidden, and i have no conditions set... is it just taking a while to come through?

     

    Thank you

    Page URL:
    https://eu.jotform.com/build/70404452046952

  • Profile Image
    JotForm Support

    Answered by BDAVID on February 16, 2017 at 02:28 PM

    It is odd, I even cleared your forms cache, but the edit vs the live version is different:

    I have forwarded this to our back-end team. You will be notified via this thread when this gets fixed.

  • Profile Image

    Answered by IanRm on February 17, 2017 at 04:36 AM

    Thank you - it is working now - must have taken time to come through - interestingly, there's one other problem: a couple of my unique field names aren't working in the text section when I go to preview - particularly {CustFirstTag} and {headerNotes} -  I've tried changing the field name, saving, and putting the new field name into the text but still not working - might this be an issue that will fixed after a number of minutes or hours also?

  • Profile Image
    JotForm Support

    Answered by Boris on February 17, 2017 at 05:55 AM

    Thank you for letting us know that the original issue resolved itself - it was likely data replication lag between our datacenters in US and datacenters in EU.

    When it comes to the issue with some of the fields seemingly missing from the email notification, please make sure that there is a label entered on each line as well. This is your current email notification setup:

    Because the Hide Empty Fields advanced options is enabled, if a line in the table has an empty label or empty content, that line will get hidden.

    Either disable the Hide Empty Fields advanced option, or add some labels for these fields:

    If you experience any other problems, please do open a separate / dedicated support thread - one per each issue. This helps us better assist you, and avoids unnecessary confusion from handling multiple issues on the same support thread. Thank you.