Stripe payments creating token but not a charge.

  • Profile Image
    Allanarobinson
    Asked on February 20, 2017 at 01:01 PM

    I have a form set up with Stripe payments. When the user submits the form, a token is being created but a charge is not being submitted to be processed. Stripe has looked at my logs and this is the issue. I need to know how to fix this before my client's trial period ends on March 2nd. 

  • Profile Image
    EltonCris
    Answered on February 20, 2017 at 02:27 PM

    I think it is due to the trial period set in your subscription.

    This means that the product is free for 10 days period. I believe the charge will follow after that.

    Another thing is, the amount of your first payment should not be less than the original price. First payment should be (Setup Fee + Regular Price)

    Hope this information helps!

  • Profile Image
    Allana Robinson
    Answered on February 20, 2017 at 04:00 PM

    Then why in my Stripe account doesn't it say that the charge was declined? And that their next charge is $65? Stripe checked my logs and says a token was created but no charge was initiated- and there's failed $1 charges in my account. 

  • Profile Image
    Nik_C
    Answered on February 20, 2017 at 05:44 PM

    Helo Allana,

    Do you have any information why that charge failed? Since when you integrate the form with Stripe, nothing related to charging is happening in the form, but it's sent to Stripe's payment processor.

    So if you could give us more information about the failing of the charge and why it failed it would be helpful.

    Thank you!

     

  • Profile Image
    Allanarobinson
    Answered on February 20, 2017 at 11:07 PM

    Hi Nik, 

    It says Service Not Allowed for all of them. When I asked Stripe CS what was going on- they said the form isn't triggering a charge, just a token. So It's creating a customer- but the charge isn't processing. 

  • Profile Image
    Ian
    Answered on February 21, 2017 at 12:34 AM

    I am forwarding the issue to our Development team so they can investigate the issue and update us.

    You will updated about the progress in the same thread.

    Thanks for your patience.

     

     

  • Profile Image
    Allana
    Answered on February 21, 2017 at 09:15 AM

    Thank you Ian I look forward to getting this resolved. 

  • Profile Image
    NeilVicente
    Answered on February 25, 2017 at 09:42 PM

    Hi Allana,

    This bug is now fixed.

    Trial payment should be charged properly from here on out.

    Kindly test it out and let us know what you think.

    Best,