Styling changes when saving the form through the Advanced Designer

  • Profile Image
    xe7en
    Asked on February 22, 2017 at 06:18 AM

    Hi,

     

    i just want to make my form responsive. But as soon as i click on the button "Advance Designer" the form loose any css / styles. See below:

     



    i think its a system error, because i already test it on any browser (Firefox, Google Chrome, IE).

     

    Thanks for help! 

  • Profile Image
    Boris
    Answered on February 22, 2017 at 08:37 AM

    I have checked your form, and it seems to have been created a long time ago with a different version of our Form Builder.

    What happens with each form is that it has some internal styling, which is inserted by the Form Builder / Designer, and it has custom CSS section where you enter your custom styles. The internal styles are added by the Form Builder when you use any styling option of the Builder/Designer, such as when you select the page background color, text color, and similar options:

    Your form was created with a previous version of the Form Builder / Designer, which added those internal styles according to the options available in that version of our Form Builder. You are currently using our Form Builder version 4, which creates those internal styles slightly differently, so the old styles got overwritten.

    Now, if you want to add back all those styles which were created by the old version of our Form Builder, you can simply insert them at the start of your custom CSS section inside our current Form Builder. They will become your current custom CSS. Here are the internal styling codes that your form lost by the new Designer:

    http://pastebin.com/raw/19ZXrSEk

    Please let us know should you need any further assistance, and we'll be glad to help. Thank you!

  • Profile Image
    xe7en
    Answered on February 22, 2017 at 08:56 AM

    so there is any option to make this form responsible without loosing the css styles?

     

    i have worked so long on this form, but since Jotform V4 nothing works right before. Dont change the working system! :( 

  • Profile Image
    KadeJM
    Answered on February 22, 2017 at 12:43 PM

    We do apologize about that, I know it may be rather frustrating from your point of view and we appreciate the report about this problem.

    About the only other way would be just to try adding more via the CSS tab using injected css without going into the form designer.

    I know the V4 Form Designer is a bit wonky still but, I know our devs will improve it more over time.

    You could always try switching back and using the V3 Form Builder which is still available.

    Additionally, with my experience of the Form Designer I've noticed it doesn't reflect it as accurately but, has improved a lot and will only get better. 

    So normally what I tend to do is keep my form open via the form link so that I can see the actual look of the overall form.

    We will investigate this further to see about what else we can do to help you more.