Blank Fields Appear In Email When You Edit Submission

  • Profile Image
    psllcom
    Asked on February 23, 2017 at 07:38 PM

    I have my notification and autoresponder emails setup so that blank fields are hidden. This feature works fine when someone submits the form, however, it does not work if we or the user edits the submission via the link at the bottom of the email.

    I've included an attachment to show this. The email on the left side is the original submission. The email on the right side is after the edit button was clicked at the bottom of the email and the submission was edited. You can see that once the form is edited the notification email no longer follows the "Hide Blank Fields" option.

    Any suggestions?

     

  • Profile Image
    Ian
    Answered on February 23, 2017 at 11:40 PM

    I am forwarding the issue to our Development team so they can look into it and update you in he same thread.

     

  • Profile Image
    psllcom
    Answered on February 25, 2017 at 10:30 AM

    Thank you.

  • Profile Image
    psllcom
    Answered on February 27, 2017 at 05:58 PM

    Just wanted to see if there were any updates to this issue?

    Also, I had several issues with my Jotform account in the hours after I posted this original question. We have two forms that we actively use for our business and both experienced issues. Both forms stopped integrating their gathered data into our Google Sheets which caused pretty big issues for our company. We didn't realize this had happened until the day after and we had to do an hours worth of work or more to clean up the mess that was made. I'm assuming this is related to someone accessing our account and testing things? If that's the case then we'd ask that Jotform find another method for testing things because our business greatly depends on these forms for day to day operations (order placements, etc) and we cannot afford any downtime between 6am-Midnight Eastern Time. If someone wants to test between Midnight and 6am, that shouldn't be an issue so long as our forms are 100% operational at 6am.

    Thanks.

  • Profile Image
    Ian
    Answered on February 27, 2017 at 08:27 PM

    The Initial issue had been escalated to the Developer team. I haven't heard any updates from that yet.

    You will be notified on the same thread as soon as it is resolved.

    i had submitted a new thread for another issue addressed by you at https://www.jotform.com/answers/1077512 , You will be replied shortly on that new thread.

     

     

  • Profile Image
    ceren
    Answered on March 07, 2017 at 08:15 AM

    Hello psllcom,

    We're sorry for the inconveniences. Blank fields issue on edit submission emails is fixed. I've tested it with a clone of your form and it's working without any problems.

     

    If you have any other questions please let us know.