Unable to view encrypted submissions in iOS mobile device

  • Profile Image
    expeditedtxpt
    Asked on February 28, 2017 at 07:36 AM

    I have tried this several times and it hasn't worked for me. After I sync the key in iTunes and restart the app, clicking the "key" icon doesn't decrypt the text. It works fine on Jotform.com though.



    This is a re-post of a comment on How to view Encrypted Submissions in the iOS Mobile App

  • Profile Image
    Mike_G
    Answered on February 28, 2017 at 10:58 AM

    Apologies for any inconvenience. As I don't have the necessary device needed to further test this and try to reproduce the issue you are having, I will ask one of my colleagues (that has the devices) to look into the issue for you.

    Thank you.

  • Profile Image
    KadeJM
    Answered on February 28, 2017 at 11:34 AM

    Hello Chris,

    Our Mobile App Team appreciates the report about the encrypted submissions not working for you and we'd be happy to look into this issue.

    I've tested this myself a few times and it is working normally on my end. I switched to one of my user test accounts, synced the jotform encryption key, and was able to decrypt the submission.

    I have also checked your account but currently, I did not find anything wrong so I would like to ask you a few more questions so that we can get to the bottom of this problem.

    What iOS device are you using? 

    And what iOS Version do you have?

    Have you renamed the jotform.key to something else? Doing this can break the functionality.

    I also see you have two forms on your account so I am wondering are both of them giving you this same problem with decryption in the app?

    Additionally, can you please try it again one more time to see if there's any difference now otherwise let us know if there's still a problem.

  • Profile Image
    Chris
    Answered on March 06, 2017 at 12:09 PM

    It works!

    I think it didn't work at first due to issues with my iTunes. It was not able to update automatically (I had to download Apple Software Update before updating iTunes to 12.5.5).

    The later attempts didn't work because the new encryption keys I downloaded were saved as "jotform.key (1)" etc. Stupid mistake.

    I apologize for not responding sooner. Email notifications of your responses didn't go to my inbox!

    Thank you for your help!