WorldPay Integration With Jotform

  • Profile Image
    golfguard
    Asked on March 01, 2017 at 07:19 AM

    Hi,

    We are unable to complete a test transaction with Worldpay using Jotform. If you look at our form:

    https://form.jotform.co/70313795521858

    You will see that we have tried to set it up as test mode and sandbox mode, but when we complete the form, we get the error that we have attached as a screenshot.

    We cannot activate our worldpay account without them seeing that a test transaction can be carried out.

    Researching this, your other users have also had problems with WorldPay and I wonder if you have a fix for this?

    I look forward to hearing from you.

    Please reply to jake@web-marketing.co.uk also.

    Best regards.

     

  • Profile Image
    liyam
    Answered on March 01, 2017 at 11:25 AM

    Hello,

    While your worldpay account is set to Sandbox/Test mode, have you set on your Payment wizard to Test mode as well to see if the error still happens?

    Thanks.

  • Profile Image
    golfguard
    Answered on March 02, 2017 at 05:38 AM

    Hello Liyam,

     

    Thank you for the reply.

     

    We have tried submitting the form with both test mode and sandbox mode on and we still get the same issue when you go through to WorldPay.

     

    Essentially, our WorldPay account is in test mode right now, and it seems that the Jotform form is treating WorldPay as though it is in live mode. We have “test mode” and “sandbox” mode selected in the WorldPay integration wizard in Jotform, but we cannot complete a test transaction as we get an error, which we have attached.

     

    Our client is becoming very frustrated, when we simply need WorldPay and Jotform to integrate correctly. I know you don't differentiate between free and paid, but our client will be a big user and once we have everything set up, we can begin paying. We can't proceed until this is set up correctly.

     

    I hope to receive a reply from you shortly with a fix for this.

  • Profile Image
    liyam
    Answered on March 02, 2017 at 06:54 AM

    Hello,

    The screenshot I shared is a setting on your Payment wizard, which shows that it is set to live mode. 

    As how I understand the situation, you have on your Worldpay account a test mode setting, while your form's Worldpay integration is set to live.

    Please take note that these two are different settings. Meaning when you have on your form a live setting, it will submit to a live URL of Worldpay. So if your Worldpay account is set to test mode, then there will be an error.

    Simply, you just need to switch your payment field's mode to test in order to switch it to test mode. But you do not need to do it anymore, I had switched it for you.

    Please test again your form to see if you are able to successfully make a payment submission.

    Thanks.