Redirect to custom thank you page hangs

  • Profile Image
    Chris Lawrence
    Asked on June 18, 2012 at 08:37 PM

    I have a form with a redirect to a custom thank you page.  When the user has submitted the form, the redirecting animation shows up but it just stays there and doesn’t go to the redirect page.  All confirmation emails are sent.  This issue has been reported by our client who can reproduce the issue (using I.E.9) and they have had a number of reports from their customers of similar problems.  However, we are unable to reproduce the issue ourselves.  I have had a look though the forums but have been unable to find a solution.  I have also checked to see if there are any conditions set on the form which could be conflicting with the redirect but I found none.  Can anyone provide any insight into what might be happening?

  • Profile Image
    NeilVicente
    Answered on June 18, 2012 at 09:44 PM

    Chris,

    I am not sure if this is what exactly causes your issue, but your page does not have the proper doctype declaration.

    Kindly use this doctype tag for the site:

    https://gist.github.com/1284173

    Get back to us if the problem still persists.

  • Profile Image
    Chris Lawrence
    Answered on June 27, 2012 at 12:41 AM

    Thanks for your answer NeilVicente. My current doctype is HTML5, are you saying that JotForm does not support HTML5?

  • Profile Image
    liyam
    Answered on June 27, 2012 at 09:46 AM

    Can you please try to clear your cache and try again.  I just tested your form using firefox and ie9 and I was able to get to your thank you page.

    Thanks.