What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Problem with Jotform-Zapier integration

    Asked by luvillos on March 07, 2017 at 08:57 AM

    Hi, 

    I´ve been trying to connect Zapier and Jotform, but i´ve run into this problem:

     

     

    I´ve already seen this forum question and tried every option described in it, but the problem persist. I think the problem might be the API limit, so i would like to kindly ask you for help, and see if reseting the API limit could be a way to solve this problem.

    Hope to hear from you soon. 

    Thanks in advance!

     

    Page URL:
    https://form.jotform.com/70613334294958

    Screenshot
  • Profile Image
    JotForm Support

    Answered by Kevin_G on March 07, 2017 at 11:37 AM

    I  have tested this on my end and I can see it works fine, I was able to complete the JotForm integration just fine on Zapier:

    Upon checking the account's owner of the form you shared, I can see there's not any API key, what I would suggest you is to delete the JotForm account in your Zapier account and then connect it again, this should generate the new API key and connect successfully both accounts. 

    This article will help you to delete connected apps on Zapier: https://zapier.com/help/connected-accounts/ 

    Once you reconnect your JotForm account with Zapier you can check it on your JotForm account under the API section: https://www.jotform.com/myaccount/api 

    Hope this helps. 

  • Profile Image

    Answered by luvillos on March 07, 2017 at 12:40 PM

    Hi Kevin, 

    Thanks for the answer! When i test it, i get the same answer, but then, after clicking "view your submission" i get an error message: Code 401 / Fields with no value: desc

     

    I have already filled forms in Jotform, so that is not the problem. And regarding de API key, there is not any because it doesn´t generate itself automatically when i connect the Zapier App. When should i then create it? (I have also already tried by disconnecting and reconnecting the accounts several times)

    Thanks!

  • Profile Image
    JotForm Support

    Answered by Kevin_G on March 07, 2017 at 02:37 PM

    I have further tested this and found that shared forms do not appear on the form's list, so you need to add the form's  account owner to get the form and this is may be why I cannot see the API key when I checked the form's account vyabogados, you could try adding this account and fetch the form from there. Testing with another JotForm account I can see it works as well. 

    I have also checked the API keys for your account  luvillos and found that your key ending in 2093 was used 997 times, this may be also causing the current problem in connection you're getting since free accounts are able to make 1,000 API calls per day. I have reset the limit so you can also try now. 

    The API key should be generated when you connect the Zapier app to the JotForm account, also if you would require to have more calls per day then you will need to upgrade your account, here're the limits  per account: 

    Free: 1000

    Bronze: 10,000

    Silver: 50,000

    Gold: 100,000

    Platinum: 1,000,000

    Hope this helps.