Our form submit button stopped working all of a sudden.

  • Profile Image
    DaySnyder
    Asked on March 07, 2017 at 10:10 AM

    Everything on the form works great until you go to submit. However, it won't go all the way through with the submit. There are no error pop ups on the page and it won't take you to the thank you page or actually submit the form. It was working fine several days ago and when we created it and we didn't change any settings on it either.

    This form is a for a business event and we need to get it working again as soon as possible.

    https://form.jotform.us/h3designs/MCC-85th-Annual-Soiree

  • Profile Image
    Kiran
    Answered on March 07, 2017 at 12:41 PM

    I have tried submitting your JotForm and was unable to submit the form though I selected No for Pay now field. As I inspect the form, I see that the product in the payment is selected by default which is displaying the amount in the payment field. Since there is amount filled in the payment field, the form is not allowing to submitting the form without entering the Credit card information. 

    Please disable the Selected by default for the product in the payment field and it should be working fine. Please see the screencast below for assistance.

    Hope this information helps! 

     

  • Profile Image
    DaySnyder
    Answered on March 07, 2017 at 12:58 PM

    That seems to have done the trick, though I still don't understand why it worked just fine before now! Thanks though.

  • Profile Image
    Kiran
    Answered on March 07, 2017 at 02:05 PM

    You are welcome. Glad to see that the issue is now resolved for you. Please do not hesitate to get back to us if you need any further assistance. We will be happy to help.

    Thank you for using JotForm!