How do I add a default tick in a check box in payment field?

  • Profile Image
    Heckington
    Asked on June 20, 2012 at 01:37 PM

    I have seen that there is a way to do this without embedding forms, so that the checkbox could be unticked if required, but it shows pre-ticked at the beginning of the form.

    Thanks

  • Profile Image
    jonathan
    Answered on June 20, 2012 at 04:20 PM

    Hi Heckington,

    Do still have the link/URL where you have seen it done without embedding the forms? We can check how it was done.

    As far as I know, using the source code embed and applying some outside script to make a default checkbox checked was the most done to achieve it.

    I remember Wayne (a.k.a Abajan), one of our support team here offering the solution to one of the user. I will try to look for the link of that post for you. Perhaps that could help already on your requirement.

    FYI

    Thanks.

  • Profile Image
    Mike_T
    Answered on June 20, 2012 at 04:26 PM

    You can not check Payment Checkboxes within form builder, but you may try our Prepopulating feature.

    For example, please check the following links:

    http://www.jotform.com/13310301270?pleaseIndicate[][id]=1001

    http://www.jotform.com/13310301270?pleaseIndicate[][id]=1001,1002

    http://www.jotform.com/13310301270?pleaseIndicate[][id]=1001,1002,1003

    Note: You will not get the Total updated based on that prepopulating feature.

  • Profile Image
    jonathan
    Answered on June 20, 2012 at 04:39 PM

    @Heckington

    Mike_T's suggestion is better too. Just take Note of the Total exclusion.

    I found one of Wayne's source code method on this post;

    -How-can-I-require-1-of-the-products-listed-to-be-purchased

    Hope this help.

    Thanks.

  • Profile Image
    Heckington
    Answered on June 21, 2012 at 12:24 PM
    Thanks very much, I have added both of these options which gives me exactly what – a default tick in the check box




  • Profile Image
    Heckington
    Answered on June 21, 2012 at 01:11 PM

    I have just tried the form in my own website and its not working. It is not showing any of the changes I have made

    It shows clearly in Preview on JotForm, but even though I have cleared my cache and tried on another PC, the amended form is not showing.

    The form link I am using is http://form.jotform.com/form/13310301270

    Please could you look at this for me?

    Thank you

  • Profile Image
    NeilVicente
    Answered on June 21, 2012 at 03:11 PM

    @Heckington

    We're having some issues with the CDN servers hosting our forms. Try using http://www.jotform.com/form/13310301270 instead.