All our forms have changed to full width, graphic buttons disappeared on our web page

  • Profile Image
    avantinnovations
    Asked on March 09, 2017 at 05:33 PM

    It appears that all 50 of our forms have changed to full width including fields and buttons. Also, any forms that had custom graphic buttons have changed to a plain grey button.

    These forms appear normal when viewed in the 4.0 builder and previewed. Also, any changes made show normal in the preview and completely different on the sites. When I revert back to 3.0 they display full width although when you click on the fields the settings still show the original field sizes.

    Is this just a bug or do we have to rebuild 50 forms?

  • Profile Image
    Kiran
    Answered on March 10, 2017 at 03:10 AM

    It seems that we have an issue with the forms displaying mobile version on the web page due to the width of the section where the form is embedded. We have reported the issue to our backend team to take a look. Once we have any update in this regard, you'll be posted here.

    Also, it would be helpful for us if you can provide us with any web page link where the form is embedded.

    Thanks!

  • Profile Image
    Kiran
    Answered on March 10, 2017 at 06:13 AM

    The issue should be fixed by now. Please check the web page and the form should be displaying correctly. Let us know if you notice any further issues with the form. We will be happy to take a look again.

    Sorry for the trouble caused.

  • Profile Image
    avantinnovations
    Answered on March 10, 2017 at 10:41 AM

    No, the issue is still affecting some forms. I have not had time to go through all of them yet but here are a few examples of the issue.

    The form is in the footer. - http://carefreebirding.com/

    The form in the top Quick Contact - http://avantinnovations.com

    Thank you.

     

  • Profile Image
    Kiran
    Answered on March 10, 2017 at 12:44 PM

    The contact page on http://avantinnovations.com seems to be displaying the form as seen it using the direct link. The other form in the footer of http://carefreebirding.com/ is displaying the fields a little which could be due to the custom CSS code injected to the form. Could you check the CSS code in the form and let us know if that works? 

    Let us know if you need any further assistance. We will be happy to assist.  

  • Profile Image
    avantinnovations
    Answered on March 10, 2017 at 01:06 PM

    I don't know how to be more clear. These forms did not look like this before and no one has gone in and made changes to make them look like this. The forms were built years ago and we never had an issue until a few months ago.

     

    Also in trying to make changes to the forms on www.stellarmedical.net, no changes made in the 4.o builder show on the site. It looks to be ok when you click preview form but the changes are not reflected on the site.

    If this was caused by the upgrade and we have to rebuild and restyle all forms then we might as well move to a new service.

     

  • Profile Image
    avantinnovations
    Answered on March 10, 2017 at 01:18 PM

    If you look at the newsletter form at the bottom of www.stellarmedical.net, it does not look like the form that is previewed.

    I tried to add a new input field and i see that i get different options when i edit. I think the old forms are not compatible with the new system and this is causing the errors.

    I need this form to look correct and have already spent too much time making changes that are not displaying. This is a simple form and i should not be having all these problems.

  • Profile Image
    jonathan
    Answered on March 10, 2017 at 05:22 PM

    Can you please confirm first that the newsletter form you were referring to was this form https://www.jotform.us/form/30437325581149

     

    I see it on the website page

     

    I just want to be sure we are checking the correct form that have the issue.

    As of this checking, I see the form using its own URL and compared to how it looks on the website, they were actually near identical.

    The clear difference is that the width of the input box in the website was not fully shown. But it was more likely due to the div container where the form was positioned -- the width of the div container where the form was embedded was too narrow for the form width.

    You can try increasing the width of the div in your website page where the form was positioned so it can show the full width.

    Ex:

     

    Let us know if issue persist.

  • Profile Image
    avantinnovations
    Answered on March 13, 2017 at 02:27 PM

    Yes, this was the form I was referring to. The div size was not the issue as it has been that size for years. The form used to have no spacing between the button and the field (I did fix this today). The spacing appeared with whatever changes JotForm made in the past few months. We have been using your service since 2011 and it seems that a lot of these forms built years ago have been affected. I tried to rebuild the form and the options are different than what I see when editing the old forms.

    I find it interesting that we seem to be the only ones affected by this issue. It seems some older code is no longer being recognized and we now have to address rebuilding 50 forms.

  • Profile Image
    david
    Answered on March 13, 2017 at 05:25 PM

    We did update the default theme recently which caused some unforeseen formatting issues.  According to our developers, the code that was updated on our end has been removed.  Anything that was added recently should no longer be affecting forms.