How to use JotForm Mac App with my ver 9 Mac?

  • Profile Image
    UQCC
    Asked on March 13, 2017 at 10:20 AM

    No. It needs OS 10.10 (I'm on .9 :) )



    This is a re-post of a comment on Increase Your Productivity with the JotForm Mac App

  • Profile Image
    Kiran
    Answered on March 13, 2017 at 01:11 PM

    Unfortunately, the Mac App is compatible with OS X 10.10 and later versions only. The browser version should be working fine as normal with the earlier versions. Once you have upgraded your OS to 10, you may then use the Mac App if it is not updated again and restricted with any specific version.

    Thanks!