V3: Form Separator widget is breaking form layout

  • Profile Image
    bhds
    Asked on March 13, 2017 at 11:53 AM

    One of our forms is not loading fully - the first three fields are being displayed, but then nothing beyond that, or even the Submit button.  This form is being used for fundraising purposes, and so it is extremely urgent that it is working properly.

    Please can you investigate and tell me why the form is not loading fully?

    Thank you.

  • Profile Image
    BJoanna
    Answered on March 13, 2017 at 02:24 PM

    I have tested your form and I was able to replicate mentioned issue. Same issue also occurred on my cloned form. Form Separator widget was causing this issue. 

    To resolve your issue remove Form Separator widgets from your form and add them back again.

    Here is my cloned form: https://form.jotformpro.com/70715932247963 

    Hope this will help. Let us know if you need further assistance. 

  • Profile Image
    bhds
    Answered on March 13, 2017 at 02:35 PM

    Removing the Form Separator widget solved the problem, but adding them back again reintroduced the problem.  Is there currently an issue with the Form Separator widget?

  • Profile Image
    BJoanna
    Answered on March 13, 2017 at 03:57 PM

    I was able to replicate  mentioned issue in Version 3 of our form builder. I will escalate this issue to our developers and we will inform you via this thread once this issue is resolved. 

    For now I can only suggest you to switch to Version 4 and add Form Separator widgets, to your form.

    You can switch to Version 4 on settings page of your account.

     

  • Profile Image
    BJoanna
    Answered on March 17, 2017 at 06:12 AM

    This issue is now resolved. You can add Form Separator widgets to your form in Version 3 or in Version 4 of our Form Builder. 

    Let us know if you need further assistance.