What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form not working with IE 11

    Asked by joekreuser on March 14, 2017 at 03:26 PM

    My form used to work with both Chrome and IE 11. All of a sudden it won't display in IE 11.

  • Profile Image
    JotForm Support

    Answered by Mike on March 14, 2017 at 04:53 PM

    Do you get any specific error in IE 11?

    I have tested the form using IE 11 from two different computers but was not able to reproduce the issue.

  • Profile Image

    Answered by joekreuser on March 14, 2017 at 05:46 PM
    Thanks for the response.
    No error comes up. Nothing at all comes, just a white screen where the form should be
    [cid:image002.jpg@01D29CDB.83322C40]
    Joe Kreuser | T 952 204 6049 | M 952 221 9187
    ...
  • Profile Image
    JotForm Support

    Answered by Mike on March 14, 2017 at 06:10 PM

    Could you please open browser developer tools (F12 hotkey) and check if there are any errors in red?

    Please share a screenshot with us if possible, see the next thread to find out how to add a screenshot.

    How to include screenshot image in the support forum

  • Profile Image

    Answered by joekreuser on March 15, 2017 at 10:46 AM
    I’m not seeing any
    [cid:image001.jpg@01D29D6A.7F9BD920]
    Joe Kreuser | T 952 204 6049 | M 952 221 9187
    ...
  • Profile Image
    JotForm Support

    Answered by david on March 15, 2017 at 01:22 PM

    I also checked the form in IE11 and everything showed up on my end.  Is there anything in the version of IE you are using that may be blocking our resources?  As far as I can tell, the form should work in IE11.