Google Spreadsheet Integration: Formula "=TEXT()" is showing in Submission ID field

  • Profile Image
    mediatask
    Asked on March 18, 2017 at 05:37 PM

    Hi Guys,

    We're experiencing the same issue.

    Some ID's are OK, while others are not, see below:

    EDIT:

    I made a test just now and made changes to the first form in the above list (ID 35071179...) and saved them.

    Here's what happened:

    So it looks as though only the newly created/changed form get the incorrect sumbission ID's

    Hope this helps you fix this issue quickly!

  • Profile Image
    Chriistian
    Answered on March 19, 2017 at 05:12 AM

    Hi there,

    I have forwarded your concern to our development team. You will be informed once this is fixed.

    Regards.

  • Profile Image
    ramblenos
    Answered on March 19, 2017 at 05:14 AM
    Hello, still not working, can you give me another solution?
  • Profile Image
    Jim_R
    Answered on March 19, 2017 at 11:52 AM

    @ramblenos - Here's your original thread https://www.jotform.com/answers/1094289 From how I see it, there are no updates yet so please stay tuned.

    If you have something to add or have a followup question, please don't reply via email. Instead, open your thread by clicking this link, then kindly post your reply from there.

  • Profile Image
    jinnie3009
    Answered on March 20, 2017 at 06:05 AM

    I have the same problem with my form and the data is unable to sync to spreadsheet after editing the submission in form.

    http://www.jotform.me/form/50688496585475
  • Profile Image
    Ian
    Answered on March 20, 2017 at 08:11 AM

    @jinnie3009 : I had moved your concern to a separate thread at https://www.jotform.com/answers/1096154

    You will be replied shortly on the newly created thread.

  • Profile Image
    mediatask
    Answered on March 21, 2017 at 02:37 PM

    Guys,

    I tried to disable and re-enable the google spreadhseets integration but instead of helping this made matters worse!

    The Submission ID colulmn now displays an ERROR.

    Here's a breakdown, which should help you nail down the bug:

    1. before the problems started this column displayed only the number, for example:

    350711792991857316

    2. when the bug appeared new or edited entries started showing a stringified formula (note the apostrophe at the beginning!), like this:

    '=TEXT("350711792991857316","0")

    3. after resetting the integration ALL entries show a formula (no apostrophe, so GS doesn't treat it as a string), like this:

    =TEXT("350711792991857316","0")

    Up until #2 we managed to workaround by using the Subsitute funciton in GS but now (#3) we're completely screwed.

    When will this be fixed?

  • Profile Image
    Jim_R
    Answered on March 21, 2017 at 04:00 PM

    Sorry for the troubles but we still haven't heard from our Developers about this so I'm following up with them on your behalf.

    Seeing that the apostrophe is gone, the sheet now treats it as a formula, thus causing the #ERROR! to show up.

    I cloned your form and integrated mine with Google Spreadsheet but failed to reproduce this problem.

    Rest assured, we'll keep you apprised on this same thread when there's an update. Thanks in advance for your patience and cooperation.

  • Profile Image
    mediatask
    Answered on March 22, 2017 at 06:11 AM

    Jim,

    I reproduced this error on a completely new form:

    https://form.jotformeu.com/70802037488357

    The result is exactly the same - I get a formula instead of a number in the "Submission ID".

     

    What's more important I also confirmed yet another, perhaps even more critical bug:

    Edited submissions show up on top of the google spreadsheet and overwrite other records!

    Step 1. I created 2 submissions priort to integrating with GS and one after making the integration.

    Up until this point it works ok (except the issue with Submission ID of course)

    I then edited the second entry (test2)

    Step 2. Now the edited entry shows up overwriting entry 1!

    Step 3. A look at the jotform database shows that the data is intact, so it's only a Google Spreadsheets integration error

    In our business we strongly rely on JotForm's google spreadhseets integration and these critical bugs produce significant problems. I strongly urge you tu fix these. Please inform me when can we expect these issues to be resolved.

  • Profile Image
    Ian
    Answered on March 22, 2017 at 07:16 AM

    I had forwarded you observation to our Developer team and requested them for updated.

    You will posted in the same thread about the status update.

    Thanks for your patience.

  • Profile Image
    mediatask
    Answered on March 22, 2017 at 12:27 PM

    Waiting for the solution.

     

    Manwhile I have narrowed the problem for you even further:

    You're using a comma instead of a semicolon as the parameter separator in the function.

    Semicolon should be used as it is the GS default which will work universally. A comma apparently only works for some locations. (that would explain why you couldn't replicate the problem)

    See this related threads: 

    https://groups.google.com/forum/#!topic/flubaroo-discussion-forum/BiITtOQqGqE

    https://productforums.google.com/forum/#!category-topic/docs/spreadsheets/JTxPHAOJjFM

     

    So, if instead of

    =TEXT("350711792991857316","0")

    the integration script would produce this

    =TEXT("350711792991857316";"0")

    the problem should hopefully be resolved.

     

    At least partially.

  • Profile Image
    mediatask
    Answered on March 22, 2017 at 01:26 PM

    Guys,

    We found a workaround which involed changing the local/language settings in our Google Spreadsheets account.

    It is however a temporary workaround, I still hope you will fix the issue and let us know when we can go back to our initial setup.

  • Profile Image
    Jan
    Answered on March 22, 2017 at 05:36 PM

    Thank you for updating us. The solution you provided on this thread (https://www.jotform.com/answers/1094289) is very helpful. This thread is already assigned to one our developers and it is still open.

    We'll let you know once the issue is fixed.